Altiris™ PC Transplant 6.8 SP4 from Symantec™ User Guide
Altiris™ PC Transplant 6.8 SP4 from Symantec™ User Guide

The software described in this book is furnished under a license agreement and may be used only in accordance with the terms of the agreement.

Legal Notice

Copyright © 2011 Symantec Corporation. All rights reserved.

Symantec and the Symantec Logo, Altiris, and any Altiris or Symantec trademarks are trademarks or registered trademarks of Symantec Corporation or its affiliates in the U.S. and other countries. Other names may be trademarks of their respective owners.

The product described in this document is distributed under licenses restricting its use, copying, distribution, and decompilation/reverse engineering. No part of this document may be reproduced in any form by any means without prior written authorization of Symantec Corporation and its licensors, if any.

THE DOCUMENTATION IS PROVIDED "AS IS" AND ALL EXPRESS OR IMPLIED CONDITIONS, REPRESENTATIONS AND WARRANTIES, INCLUDING ANY IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR NON-INFRINGEMENT, ARE DISCLAIMED, EXCEPT TO THE EXTENT THAT SUCH DISCLAIMERS ARE HELD TO BE LEGALLY INVALID. SYMANTEC CORPORATION SHALL NOT BE LIABLE FOR INCIDENTAL OR CONSEQUENTIAL DAMAGES IN CONNECTION WITH THE FURNISHING, PERFORMANCE, OR USE OF THIS DOCUMENTATION. THE INFORMATION CONTAINED IN THIS DOCUMENTATION IS SUBJECT TO CHANGE WITHOUT NOTICE.

The Licensed Software and Documentation are deemed to be commercial computer software as defined in FAR 12.212 and subject to restricted rights as defined in FAR Section 52.227-19 "Commercial Computer Software - Restricted Rights" and DFARS 227.7202, "Rights in Commercial Computer Software or Commercial Computer Software Documentation", as applicable, and any successor regulations. Any use, modification, reproduction release, performance, display or disclosure of the Licensed Software and Documentation by the U.S. Government shall be solely in accordance with the terms of this Agreement.
Technical Support

Symantec Technical Support maintains support centers globally. Technical Support’s primary role is to respond to specific queries about product features and functionality. The Technical Support group also creates content for our online Knowledge Base. The Technical Support group works collaboratively with the other functional areas within Symantec to answer your questions in a timely fashion. For example, the Technical Support group works with Product Engineering and Symantec Security Response to provide alerting services and virus definition updates.

Symantec’s support offerings include the following:

■ A range of support options that give you the flexibility to select the right amount of service for any size organization
■ Telephone and/or Web-based support that provides rapid response and up-to-the-minute information
■ Upgrade assurance that delivers software upgrades
■ Global support purchased on a regional business hours or 24 hours a day, 7 days a week basis
■ Premium service offerings that include Account Management Services

For information about Symantec’s support offerings, you can visit our Web site at the following URL:

www.symantec.com/business/support/

All support services will be delivered in accordance with your support agreement and the then-current enterprise technical support policy.

Contacting Technical Support

Customers with a current support agreement may access Technical Support information at the following URL:

www.symantec.com/business/support/

Before contacting Technical Support, make sure you have satisfied the system requirements that are listed in your product documentation. Also, you should be at the computer on which the problem occurred, in case it is necessary to replicate the problem.

When you contact Technical Support, please have the following information available:

■ Product release level
Hardware information
Available memory, disk space, and NIC information
Operating system
Version and patch level
Network topology
Router, gateway, and IP address information
Problem description:
  - Error messages and log files
  - Troubleshooting that was performed before contacting Symantec
  - Recent software configuration changes and network changes

Licensing and registration
If your Symantec product requires registration or a license key, access our technical support Web page at the following URL:
www.symantec.com/business/support/

Customer service
Customer service information is available at the following URL:
www.symantec.com/business/support/
Customer Service is available to assist with non-technical questions, such as the following types of issues:
  - Questions regarding product licensing or serialization
  - Product registration updates, such as address or name changes
  - General product information (features, language availability, local dealers)
  - Latest information about product updates and upgrades
  - Information about upgrade assurance and support contracts
  - Information about the Symantec Buying Programs
  - Advice about Symantec's technical support options
  - Nontechnical presales questions
  - Issues that are related to CD-ROMs or manuals
## Support agreement resources

If you want to contact Symantec regarding an existing support agreement, please contact the support agreement administration team for your region as follows:

<table>
<thead>
<tr>
<th>Region</th>
<th>Email</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asia-Pacific and Japan</td>
<td><a href="mailto:customercare_apac@symantec.com">customercare_apac@symantec.com</a></td>
</tr>
<tr>
<td>Europe, Middle-East, and Africa</td>
<td><a href="mailto:semea@symantec.com">semea@symantec.com</a></td>
</tr>
<tr>
<td>North America and Latin America</td>
<td><a href="mailto:supportsolutions@symantec.com">supportsolutions@symantec.com</a></td>
</tr>
</tbody>
</table>
## Contents

### Technical Support

Chapter 1 Introducing Altiris PC Transplant from Symantec

- Overview ................................................................. 11
- What’s new in this release ............................................. 12
- Features ......................................................................... 12
- Personality Package installation ...................................... 13
- A2i files and A2i Builder ............................................... 13

Chapter 2 Installing PC Transplant .................................. 15

- Hardware requirements for Windows-based utilities .......... 15
- Software requirements for Windows-based utilities ............ 16
- About installing PC Transplant ...................................... 16
- Downloading PC Transplant .......................................... 16
- Installing PC Transplant for the first time ....................... 16
- Applying a PC Transplant license .................................... 17
- Installing PC Transplant on Windows Vista in Quiet Mode .... 17

Chapter 3 Getting Started with PC Transplant ................... 19

- About PC Transplant .................................................... 19
- Creating a Personality Package ...................................... 20
- Deploying a Personality Package .................................... 22
- Creating a personality build template .............................. 23
- Performing a real-time migration .................................... 24

Chapter 4 Transplanting PC’s Settings and Data .................. 27

- About transplanting PC’s Settings and Data .................... 27
- Recommendations ...................................................... 28
  - Migrating domain user accounts .................................. 29
- Creating Personality Packages .................................... 29
  - Build summary and log details ................................. 30
- Performing real-time migration using a crossover cable ....... 31
- Loading the destination agent ...................................... 33
Migration summary and log details ........................................... 33
Personality Settings options ........................................................... 34
User Account Settings and File Options ................................. 34
Personality build template options ........................................... 38
Computer settings options ...................................................... 40
Application install options ...................................................... 44
Files, folders, and file types options .......................................... 46
Capture options .................................................................... 63
Environment variable support .................................................. 65
Wildcard support ................................................................... 66
Deploy options ...................................................................... 66
Package creation options ........................................................ 69
Skip Files options .................................................................. 74
Cancelling the migration ........................................................ 74
Cleaning up source files ........................................................... 75
Password encryption utility ........................................................... 76
Viewing, printing, or changing personality package contents .......... 76

Chapter 5

Personality Package Installation .............................................. 79
Installing Personality Package ....................................................... 79
Installing summary and log details .................................................. 80
Performing actual migration after simulation ............................. 81
Personality Settings options ........................................................... 81
Selecting a user and creating new accounts ............................. 82
About migration of computer name and domain name ................. 85
Viewing the PC settings and data options ................................... 86
Using application installation options ........................................ 88
About configurable options ..................................................... 89
Personality package installation complete ................................. 91
Personality Rollback .................................................................... 91

Chapter 6

Application Install Administrator .............................................. 93
Opening the Application Install Administrator ............................. 93
About Application Install Administrator .......................................... 94
Defining the Application Installation .................................................. 94
Managing installation servers ................................................... 95
Providing a path for the Install File location ................................. 96
Using the command-line options for installation and upgrading .......... 97
Chapter 7  
Template Builder ................................................................. 99
Using the Template Builder .................................................... 99
About the Personality Build Template summary ...................... 100
Using and Editing a Personality Build Template ...................... 100
About the template settings options ..................................... 100
Adding user capture options to the template ....................... 100
Viewing the computer settings options ............................ 102
About application install options ........................................ 107
About files, folders, and file types options ....................... 109
Using the Capture options ................................................... 115
About the Deploy options ............................................... 117

Chapter 8  
PC Transplant Package Editor ........................................ 119
About using the PC Transplant Package Editor ......................... 119
Opening a Personality Package ........................................ 119
Viewing and Changing Advanced Settings ............................ 120
Viewing and Changing Registry Settings ............................. 120
Viewing and Changing Files and File Structures .................. 120
PC Transplant Package Editor Menu Features ................... 121
Extracting a File from a Package ................................... 123

Chapter 9  
Using the A2i Builder ............................................................ 125
A2i Builder ........................................................................... 125
Creating, Editing, or adding versions to A2i Files .................. 126

Chapter 10  
A2i File Settings ................................................................. 129
Select the Required Application ........................................ 129
Select the .A2i File Name ...................................................... 130
Capturing the application's settings ................................... 130
Adding Registry Items ............................................................. 131
Adding Registry Filter .......................................................... 131
Modifying a Registry, File, Folder, or File Type property ....... 131
Submitting .A2i Files to Altiris Test Site ............................. 137
Adding Files and Folders ..................................................... 133
Adding files, folders, or drives to the filter ......................... 134
Adding File Types ................................................................. 134
Viewing, Editing, or Using the A2i File ............................. 134
Creating A2i Summary ......................................................... 135
Legacy Applications ............................................................. 135
Submitting .A2i Files to Altiris Test Site .......................... 137
Introducing Altiris PC Transplant from Symantec

This chapter includes the following topics:

- Overview
- What’s new in this release
- Features
- Personality Package installation
- A2i files and A2i Builder

Overview

Altiris PC Transplant from Symantec uses its wizard-driven interface to capture a computer’s personality. It captures items such as the user account; desktop, network, and application settings; files; folders; and personal data as part of a computer’s personality. You can then transplant those items and the computer’s personality to another computer. You can use a self-extracting executable file that is called a Personality Package or you can perform a real-time migration from one computer to another.

PC Transplant simplifies the deployment and migration of new computers or Windows operating systems by helping you migrate the data and settings. It complements the existing desktop management tools and meets an easily identified need that those tools do not address. With PC Transplant, you can migrate to a new computer quickly and efficiently. You can also transfer key aspects of a computer’s personality between multiple computers.

PC Transplant is an ideal solution for IT administrators, consultants, VARs, resellers, computer vendors, and configuration centers.
What’s new in this release

In this release, we added the following new features to PC Transplant:

■ Support for Windows 7 (client OS only)
■ Support for migration settings of Internet Explorer 8.0
■ An option to migrate encrypted files in their raw state with EFS.
  See “Migrating EFS encrypted files” on page 64.
■ A Legacy Applications folder for a2i files.
  See “Legacy Applications” on page 135.

Features

PC Transplant lets you upgrade to a new computer by performing a real-time migration or by running a Personality Package file. Similarly, you can upgrade to a new operating system. PC Transplant also creates user accounts during migration.

Real-time migration is the migration of the computer personality in real time, which eliminates the need to create Personality Packages. In real-time migration, you can map users and user properties, create user accounts, and install applications.

PC Transplant lets you create personality build templates in the personality template builder tool. These templates help you capture a computer’s settings in a Personality Package and can be run from command-line options to automate the operating system migrations. The personality template builder lets users build and edit templates to define the settings, files, and options that are used to create Personality Packages.

PC Transplant lets you create Personality Packages that can be used for multiple purposes.

See “Creating a Personality Package” on page 20.

Personality Packages can include the desktop, network, printer, application settings (such as templates, favorites, and contacts), and entire directory structures of your computer. When a Personality Package is run on a destination computer, the settings that you captured are applied to the destination computer. You can also create Personality Packages for individual users on a shared computer. Individual users can install the Personality Package and work on the shared computer. They can then uninstall the Personality Package after they are finished using that computer.
You can create a Personality Package that contains the most used directories, documents, and settings. You can then build a new Personality Package to capture the most recent changes for multiple computers. You can also create a Personality Package that can be shared with multiple computers across a network.

PC Transplant provides a wizard that lets you identify and transplant users, settings, file, and directories. You can migrate the data that you have identified across a network or by building a self-extracting executable file. The wizard lets you create rules to capture settings, file, directories, and users. You can also define the behavior of a Personality Package after it is run on a destination computer.

### Personality Package installation

The Application Install Administrator tool in PC Transplant can evaluate the application versions that are installed on a computer. The tool reads the Application to Information (.A2i) files and find the supported version to install the applications on the destination computer before you migrate the settings. This tool lets you install an application of the same or higher version on the destination computer. The tool creates a file that can also be used for providing the application installation information during migration.

### A2i files and A2i Builder

The A2i files describe the components that are needed for transferring the settings and the data files of an application. Each A2i file is specific to the application. The wizard uses these files to show the user what application settings can be migrated and how to collect this information.

PC Transplant also provides the A2i Builder tool that helps to create customized A2i files for an application.

See “Using the Template Builder” on page 99.

For details on using PC Transplant, See “About PC Transplant” on page 19.
Installing PC Transplant

This chapter includes the following topics:

- Hardware requirements for Windows-based utilities
- Software requirements for Windows-based utilities
- About installing PC Transplant
- Downloading PC Transplant
- Installing PC Transplant for the first time
- Applying a PC Transplant license
- Installing PC Transplant on Windows Vista in Quiet Mode

Hardware requirements for Windows-based utilities

The following hardware prerequisites are required for installing PC Transplant on your computer.

PC Transplant also supports migration to Windows 7 computers (client OS only).

Note: For best results, use the recommended minimums that are provided in brackets.

Windows XP:
- Pentium 300 MHz (400 MHz)
- 128 MB RAM (192 MB)
- 64 MB free disk space (128 MB)

Windows Vista:
Software requirements for Windows-based utilities

Your computer must meet the following software prerequisites before you install PC Transplant.

- Microsoft Internet Information Server (IIS)
- Internet Explorer 4.0 or later

About installing PC Transplant

Once you have the required hardware and software on your computer, you can download and install PC Transplant.

You can download PC Transplant from http://www.altiris.com/Download.aspx. You can also upgrade previous versions of PC Transplant (6.1 or later) from the same location.

Downloading PC Transplant

You can download PC Transplant from http://www.altiris.com/Download.aspx. You can also upgrade it from previous versions (6.1 or later) from the same location.

Installing PC Transplant for the first time

After you have downloaded PC Transplant, you can install it on your computer.
To install PC Transplant for the first time

1. Run PCTSetup.exe from the files that you downloaded.

2. In the Language list of the Altiris PC Transplant dialog, select the language you want.

3. On the Welcome screen, click Next.

4. On the Altiris Activation Key Wizard screen, provide a valid activation key, and then click Next.

5. Read and accept the license agreement.

6. Click Next.

7. On the Destination Folder dialog, select the location to install PC Transplant, and then click Next.

8. On the Ready to Install the Application dialog, click Next to install PC Transplant.

Applying a PC Transplant license

You must apply valid licenses to install PC Transplant on your computer.

To apply a PC Transplant license

1. From the Windows Start menu, click Start > Programs > Altiris > PCTransplant > Product License Utility.

2. From the Altiris License Activation Key wizard, browse and select the license key.

3. Click Next.

4. On the Select Altiris Program Files to Activate dialog, click Add.

5. Browse and select the PCTLic.dat file.

6. Select Replace all existing license Activation Keys with this new Activation Key.

7. Click Finish.

Installing PC Transplant on Windows Vista in Quiet Mode

Microsoft provides guidelines to install applications on a computer that is running Windows Vista.
According to these guidelines, an application can be installed in the Quiet Mode using the following command line:

```plaintext
Msiexec /I <Application installer package>.msi /qn FASTOEM=1
```

However, the PC Transplant installation fails if you use the `FASTOEM=1` command.

To install PC Transplant on Windows Vista in Quiet Mode

1. As an administrator, use the following command:
   
   ```plaintext
   PCTSetup.exe /qn INSTALLDIR="<install location>"
   ```
   
   For example,
   
   ```plaintext
   C:\Folder>PCTSetup.exe /qn INSTALLDIR="C:\Program Files\Altiris\PCT"
   ```

2. From the Altiris PC Transplant dialog, select the installation language for PC Transplant.
   
   The setup continues in Quiet Mode.

3. Use the following command to view the confirmation dialog at the end of the installation. A message that indicates if the installation was successful appears on the confirmation dialog.
   
   ```plaintext
   PCTSetup.exe /qn+ INSTALLDIR="<install location>"
   ```
   
   For example,
   
   ```plaintext
   PCTSetup.exe /qn+ INSTALLDIR="C:\Program Files\Altiris\PCT"
   ```
Getting Started with PC Transplant

This chapter includes the following topics:

- About PC Transplant
- Creating a Personality Package
- Deploying a Personality Package
- Creating a personality build template
- Performing a real-time migration

About PC Transplant

You can use PC Transplant to create and deploy a Personality Package, create a personality build template, and perform real-time migrations.

For example, consider that your company wants to hire new employees, move to a larger site, and replace its old computers with upgraded ones. You can use PC Transplant to simplify that entire process. You can create the Personality Packages that contain the computer settings for each of the current employees. You can then deploy those packages to the upgraded computers in the new site. By creating a build template, you can include all of the standard settings and files that the new employees need. You can also use PC Transplant to migrate your servers, while ensuring that they have minimum down time and function in the quickest possible time. PC Transplant also lets you maintain a copy of all user profile data for users who move on to other projects.
### Table 3-1  Process for using PC Transplant

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Create a Personality Package</td>
<td>You can create a Personality Package that includes all of the current settings for each computer that is in your environment. See “Creating a Personality Package” on page 20.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Deploy a Personality Package</td>
<td>You can deploy a Personality Package that you previously created. This package lets you move or copy all of the settings from one computer to another computer. See “Deploying a Personality Package” on page 22.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Create a personality build template</td>
<td>A personality build template can include all of the standard settings and files for the computers in your environment. See “Creating a personality build template” on page 23.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Perform a real-time migration</td>
<td>PC Transplants lets you migrate your data from one server to another in the quickest time possible. See “Performing a real-time migration” on page 24.</td>
</tr>
</tbody>
</table>

### Creating a Personality Package

A Personality Package is a self-extracting executable file that contains the user accounts for a computer. These accounts include the desktop, network, and application settings, files; folders; and all personal data. Creating a Personality Package simplifies the deployment and migration of new computers or Windows operating systems.

In Windows Vista, the executable file is not self-extracting.
To create a Personality Package

1. From the Windows Start menu, click **Start** > **Programs** > **Altiris** > **PCTransplant** > **PC Transplant**.
   
   The **PC Transplant Application Support** dialog appears. This dialog lets you download the latest desktop, network, and application definition files (.ini and .A2i files).

2. From the **Welcome** page, click **Create a new package**.

3. Click **Next**.

4. Select the personality build template to use, and then click **Next**.

   The **Common Predefined Templates** option and the **Default.pbt** options are common options to choose from the list of predefined templates.

5. Set the accounts option to select one or multiple user accounts to migrate.

   You can filter the user accounts based on groups, domains, or the date criteria.

   The **Include Disconnected Users** option displays any additional accounts that are no longer used or that their assigned domains cannot validate. If there are no orphan accounts or disconnected accounts, this box is disabled.

6. Select the computer that you want to transplant the settings for, and then click **Next**.

   You must have administrator rights on the domain of the source computer to migrate the computer name and domain name settings.

7. Select the files, folders, and file types to transplant, and then click **Next**.

8. From the **Capture Options** page, set the span, compression, self-extracting package, and advanced options.

9. Click **Next**.

   By default, the **Create a self-extracting package (not recommended for Windows Vista)** box is selected for non-Windows Vista computers. If you select this box for a Windows Vista computer, a .exe file is created as the self-extracting package. If you do not select this box for a Windows Vista computer, .exe and .pkg files are created as the Personality Package. The .pkg file is not associated with PC Transplant. You must use the .exe file to run the .pkg file.

   Under **Advanced Options** and the **Security** tab, use the **Migrate file and folder security permissions** option to migrate the permissions that are associated with the selected files or folders.

10. From the **Deploy Options** page, set the display, Quiet Mode, file replace, and advanced options.
Click Next.

(Optional) Type a password in the Run/Edit field to password protect the Personality Package.

Users cannot run or edit the Personality Package unless they know the specified password.

Click the Build Personality Package box to save the Personality Package.

Specify a path name and a file name for the package.

You can save the package locally, on a UNC, or on a Web server.

Click OK to finish the process.

To stop the process at any time, click Cancel.

While the package builds, you can skip files.

See “Skip Files options” on page 74.

Deploying a Personality Package

When you run a Personality Package on the target computer, the captured settings and file are migrated to the new Windows operating system. For information about automating Personality Package installation from the command line, see the Altiris PC Transplant Reference Guide.

Personality Packages overwrite the current settings of your destination computer.

To deploy a Personality Package

1. From the destination computer, browse to the location where you saved the Personality Package.
2. Double-click the Personality Package.
3. In the personality wizard, click Next.
4. Select the accounts to migrate, create any accounts to add, and make changes to any of the existing user mappings.
5. Click Next.
6. From the list of settings that were captured during the package creation, select the settings to transplant.
7. Click Next.
8. From the Transplant Options page, set the migration options.
9. Click Begin.
Creating a personality build template

The template builder lets you define a template that can be used to create a Personality Package. Based on the template, you can define the settings, files, folders, and file types that should be a part of all Personality Packages.

All template builder templates are compatible with the PC Transplant Wizard. All PC Transplant Wizard templates are also compatible with the template builder. However, the templates that were created in the PC Transplant Wizard are computer-dependent. Settings that were defined in a template might include the items that are specific to a computer. For example, specific folders, printers, mapped drives, etc.

PC Transplant supports cross-language Personality Build Templates (PBT). When you transplant the settings of your computer, you do not need to specify a language PBT. Instead, PCTWiz translates the language PBT to the language in which PCTWiz is running.

To create a personality build template

1. From the Windows Start menu, click Start > Programs > Altiris > PCTransplant > Tools > Template Builder.
2. Click Next to start the wizard.
3. Choose a predefined template, and then click Next.
4. Select the user account settings to transplant to another computer, and then click Next.
5. Select the computer’s settings to transplant to another computer, and then click Next.
6. Select the files and folders to transplant to another computer, and then click Next.
7. From the Capture Options page, set the span, compression, self-extracting package, and advanced options.
8 Click Next.

By default, the Create a self-extracting package (not recommended for Windows Vista) box is checked for non-Windows Vista computers. If you check this box for a Windows Vista computer, a .exe file is created as the self-extracting package. If you do not check this box for a Windows Vista computer, .exe and .pkg files are created as the Personality Package. The .pkg file is not associated with PC Transplant. You must use the .exe file to run the .pkg file.

9 From the Deploy Options page, set the display, Quiet Mode, file replace, and advanced options.

10 Click Next.

11 In the Save as field, type a name and path.

12 Click OK.

13 Review the summary

14 (Optional) Click Next, and then select Open in the text editor to open the template in Notepad for further viewing and editing.

15 Click Finish to close the template builder.

Performing a real-time migration

You can transplant a source computer’s settings and files in real time through a network connection to a destination computer. This process eliminates the need to store any files or packages.

The source computer must have a TCP/IP connection to the network. To migrate application settings, the same application (but not necessarily the same version) must exist on both the source computer and target computer. If the same application is not present on the target computer, you can install it by providing the information for application installation.

See “Using application installation options” on page 88.

To perform a real-time migration

1 From the Windows Start menu, click Start > Programs > Altiris > PCTransplant > PC Transplant.

2 Click Real Time Migration, and then click Next.

3 Select the personality build template to use, and then click Next.
4 Browse to or type the name of the destination computer.

The destination agent can be loaded on the destination computer in two different ways: by pushing the agent remotely and loading the agent manually. See "Loading the destination agent" on page 33.

5 Click Next.

6 Select the accounts to migrate, and then map them to the destination user accounts.

7 Create any accounts to add, and then make changes to any of the existing user mappings.

To create local user accounts, you must have administrator rights on the destination computer. To create domain users, you must have administrator rights on the destination computer’s domain.

8 Click Next.

9 Select the computer’s settings to transplant, and then click Next.

You must have administrator rights on the domain of the source computer to migrate the computer name and domain name settings.

10 Select the files, folders, and file types to transplant.

11 Click Next.

By default, the Create a self-extracting package (not recommended for Windows Vista) box is checked for non-Windows Vista computers. If you check this box for a Windows Vista computer, a .EXE file is created as the self-extracting package. If you do not check this box for a Windows Vista computer, .EXE and .PKG files are created as the Personality Package. The .PKG file is not associated with PC Transplant. You must use the .EXE file to run the .PKG file.

12 From the Capture Options page, set the span, compression, and advanced options.

13 Click Next.

14 From the Deploy Options page, set the display, Quiet Mode, file replace, and advanced options.
15 Click Next.

16 Click OK to start the real-time migration.
   While the migration is in process, you have the option of skipping files.
   See “Skip Files options” on page 74.
   You can also cancel the migration process.
   See “Cancelling the migration” on page 74.
Transplanting PC's Settings and Data

This chapter includes the following topics:

■ About transplanting PC's Settings and Data
■ Recommendations
■ Creating Personality Packages
■ Performing real-time migration using a crossover cable
■ Loading the destination agent
■ Personality Settings options
■ Cleaning up source files
■ Password encryption utility
■ Viewing, printing, or changing personality package contents

About transplanting PC's Settings and Data

You can transplant a computer's personality (settings and data) to another computer in two ways:

■ Creation and installation of personality packages
■ Real-time migrations

When you create a personality package, the computer's settings and files are captured in a single self-extracting executable file. In addition, you can define
options that affect the way the personality package is run when it is installed on
the target computer.

You can set the profile path of the folders of the destination computer as the
profile path of the folders of the source computer during the creation of a package
for migrating the folders. You can use the -keepprofilepaths command-line option
to set the profile path. For information, see the Altiris PC Transplant Reference
Guide.

When you perform a real-time migration, a source computer's settings and files
are migrated "real time" through a network connection to a destination computer,
eliminating the need for any stored files.

You can create a personality package or perform a real-time migration using the
PC Transplant Wizard, which lets you pick and choose the settings you want to
transplant to another computer.

You can also automate a personality transplant by running the PC Transplant
Wizard with command-line options. This feature lets you initiate migrations
through batch files, login scripts, and so on. For information, see the Altiris PC
Transplant Reference Guide.

Recommendations

To run PC Transplant successfully on your source and destination computers, we
recommend:

■ An account that has access to all users on the source computer and has the
  rights to create users on the destination computer.

■ A domain user account with local administrative rights as the minimum rights
  level. If the user account does not have administrative rights on a domain,
  then local administrative rights are sufficient. If you use an account that is
  not a local administrator account or has less rights than a standard
  administrator account, you cannot create users and migrate certain settings.
  You will be forced into a limited migration. Example: You are migrating a
  printer whose drivers need to be installed. A group policy preventing users or
  power users from installing those drivers would prevent the migration of the
  printer.

■ That you always preface your user account name with a domain name
  applicable to the migration.
Migrating domain user accounts

When migrating domain user accounts, you need different rights based on the situation. You can migrate accounts on the same domain or different domains, depending on your requirement.

The following are the requirements for migrating accounts on the same domain:

■ For migrating domain user accounts, you need a domain user with rights to the local computers being migrated. Local administrative rights are preferred because of possible limitations without them.

■ For computer and domain name migration, you need administrative rights on the local computers and rights on the domain to manage computer accounts.

■ For any multiple-user migration you must be a local administrator on both machines.

When migrating domain user accounts from different domains (example: Domain A to Domain B), you need different account rights based on the situation. The following are the requirements for migrating accounts on different domains:

■ For package migration, you need a Domain A account for the source package and a Domain B account for the destination. You can also use an account that traverses both domains using domain trusts.

■ For real-time migration, you must have an account with rights to both domains and local computers.

■ For any multiple-user migration you must be a local administrator on both computers.

Note: When pushing from the Deployment Server, you can only use the Pre Windows 2000 User Name.

Creating Personality Packages

The following sections describe how to create and use personality packages:

■ Creating a Personality Package.

■ Build Summary and Log Details

■ Deploying a Personality Package.

■ Viewing, Printing, or Changing Personality Package Contents.
Build summary and log details

After a personality package is created, a summary screen appears. The summary provides the following information:

- Source computer name with the domain name
- Package filename
- The paths for all spanning packages
- Package creation date and time
- The time taken to create the package
- Number of files and their total size
- A list of the settings collected
- A list of settings for which some errors occurred
- Files skipped by the user during package creation

The Personality Build Summary page has two tabs: Summary and Capture Log.

In the Summary or Capture Log tab, click Open to view the information as a text file in Notepad application. You can then save or print the details.

In the Summary or Capture Log tab, click Save As to give a different name and path to the summary.txt and error.log file. You can use the command-line option -summary: <pathname> and -errorlog: <pathname> to do the same. For information, see the Altiris PC Transplant Reference Guide.

By default, the summary and error information is saved in the summary.txt and error.log files in the following folder of the currently logged on user's profile:

Local Settings\Application Data\Altiris\PC Transplant\version for NTx users

For information on viewing log details, see Log Details.

You can view three levels of log details.

To view the log details

1. Click the appropriate log tab to view any errors that occurred.

   - In the Error Level drop-down list, select Errors to view the errors and general messages. All the errors are displayed in the right pane. From the left pane, you can expand the tree structure and browse to the particular category to see the error messages.

     From the left pane, click the error messages icon to view the error messages.
In the Error Level drop-down list, select Errors and Warnings to view the errors, warnings, and general messages. All the errors and warnings that occurred are displayed in the right pane. From the left pane, you can expand the tree structure and browse to the particular category to see the error messages or the warning messages. From the left pane, click the error messages icon to view the error messages and click the warning messages icon to view the warning messages.

In the Error Level drop-down list, select All Messages to view all the messages. All the errors, warnings, and the detailed information on the errors that occurred are displayed in the right pane. From the left pane, you can expand the tree structure and browse to the particular category to see the error messages, warning messages, or detailed information. From the left pane, click the error messages icon to view the error messages. Click the warning messages icon to view the warning messages. Click the information icon to view the detailed information.

2 If there is a problem, click Back to redefine settings.

Performing real-time migration using a crossover cable

When you want to migrate the settings of a computer to another computer that is not on the network, you can connect the computers through a crossover cable using a command-line option, and directly migrate the source computer's settings to the destination computer. The command-line option resets the status and settings of the source computer after the migration is complete or if the migration is interrupted before completion. You can use the following command-line option to reset the status and settings of the source computer.

-reset

You can also specify the bandwidth usage during migration by using a command-line option. The command-line option to specify the bandwidth usage is

-bandwidth:<xxKB> or <xx>

This option lets you do static bandwidth throttling during real-time migration across a network or through a crossover cable. You can set the bandwidth once (example: -bandwidth:100KB) or set it based on a percentage of the available bandwidth (example: -bandwidth:10). The command-line option lets you change the speed of real-time migration across the network or through a crossover cable.
For information on command-line options, see the *Altiris PC Transplant Reference Guide*.

In real-time migration, you can also use the `-keepprofilepaths` command-line option to set the profile path of the folders of the destination computer as the profile path of the folders on the source computer. During a real-time migration, you can use this command-line option only with `-rt:network=<machinename>` command-line option. For information on command-line options, see the *Altiris PC Transplant Reference Guide*.

**To perform a real-time migration using a crossover cable**

1. Connect the source and destination computer with a crossover cable.

2. Copy the PCTCrossConfig utility from the source computer to the destination computer, and execute the PCTCrossConfig utility on the destination computer to configure it for crossover migration.

   **Note:** The PCTCrossConfig utility is located in the path where you have installed PC Transplant.

3. From the Windows **Start** menu, select **Start > Programs > Altiris > PCTransplant > PC Transplant**.

4. Click **Real Time Migration** and select the **Cross-over** cable migration check box.

5. Click **Next**.

6. If your computer has multiple network adapters, select a network adapter. Click **Next**.

   **Note:** If your computer has a single network adapter, then the option for selecting a network adapter is disabled. The PC Transplant Wizard uses this network adapter for the migration.

7. Select the personality build template to use. Click **Next**.
8  Click Next.

The **PC Transplant Wizard** configures the source computer's IP Address/Subnet Mask to 10.0.0.1/255.255.255.0 and the destination computer's IP Address/Subnet Mask to 10.0.0.2/255.255.255.0.

You can also provide a customized IP Address/Subnet Mask using the following command line. `-advcrossconfig:<IPaddress>,<Subnet Mask>`

You can configure the source and destination computers for crossover migration. This switch can be used in the PC Transplant Wizard and in the PCTCrossConfig utility. When you use this switch in the PC Transplant Wizard, you have to specify the IP address of the source computer. When you use this switch in the PCTCrossConfig utility, you have to specify the IP address of the destination computer. For information about command-line options, see the *Altiris PC Transplant Reference Guide*.

9  Continue with step 5 on **Performing a real-time migration**

### Loading the destination agent

The destination agent is a means of communication between the source and destination computers that are part of real-time migration. While performing real-time migration, the destination agent can be loaded on the destination computer in two different ways: pushing the agent remotely and loading the agent manually.

### Migration summary and log details

After a migration is completed, a summary screen appears on the Personality Build Summary page.

The summary provides the following information:

- Source computer name with the domain name
- Destination computer name with the domain name
- Migration date and time ISource Operating System
- Destination Operating System
- User Context - the name of the user who executed the package
- The time taken to migrate
- Number of files and their total size
- A list of the settings collected
Personality Settings options

This section provides details about the settings you can configure for transplanting personalities. You can easily configure these settings in the PC Transplant Wizard and Template Builder. Many of these settings can be saved in a Personality Build Template that makes it easy to re-use settings.

See “Personality build template options” on page 38.

User Account Settings and File Options

PC Transplant supports capturing and migrating files and settings for a single user, multiple users, or all users. For information on how file permissions are transplanted, see Security Options. When creating a personality package, the wizard displays all user accounts available on the source computer. From this dialog box, select one or more users from the list. All guest accounts and those accounts that have not ever logged on to the computer are filtered from this list. You can also filter user accounts based on the groups, domains, or the date criteria. See Filtering User Accounts.

Real-time migration now allows migration on the same computer. The -multiple command-line option can be used while performing real-time migration on the same computer to allow the execution of the PC Transplant Wizard and the PC
Transplant real-time destination agent. For information, see the Altiris PC Transplant Reference Guide. With the loop back functionality, you can give the same computer name and the IP address for the target computer. You can also provide the loop back IP address, 127.0.0.1, instead of the same IP address.

The loop back functionality can be used for the following:

- Migrate settings from one user to another user on the same computer.
- Import settings of an orphan account to some active user account on the same computer.
- Migrate data from one directory to another on the same computer.

When selecting which user accounts to migrate, you are shown the user accounts that exist on both the source and destination computers. You can map the settings of one user account on the source computer to any account name on the destination computer.

**User has administrative rights on both the source and destination computers**

All accounts on both computers are listed. You can map any of the accounts on the source computer to any of the accounts on the destination computer.

**User has administrative rights only on the source computer**

All accounts on the source computer and your account on the destination computer are listed. You can map any of the accounts on the source computer to your account on the destination computer.

**User has administrative rights only on the destination computer**

All accounts on the destination computer and your account on the source computer are listed. You can map your account on the source computer to any of the accounts on the destination computer.

**User does not have administrative rights on both computers**

Your account on both the computers is listed. You can only map your account on the source computer to your account with the same name on the destination computer.

The **User Properties** feature displays the users that exist on both the source and destination computers, and the groups to which they belong. Only users with administrative rights have the ability to view and migrate multiple users. If the current user running the wizard does not have administrative or system rights, only the current logged on user will be displayed for migration.

You can also create new accounts on the destination computer to match accounts on the source computer. Consider a scenario where an account named Bob exists on the source computer, but not on the destination computer, and you want to migrate that account and maintain the name. In this case, you can create an
account named Bob on the destination computer from the wizard, and then select that account to be migrated. While creating new user accounts and adding them to a particular group on the destination computer, you need to check whether the user account is already a member of the group. If the user account is not an existing member of the group, then the user account is added to the group. Example: If a domain user, Altiris\Joe, exists on the source computer and is a member of the administrator group on the source computer, then Altiris\Joe should be a member of the administrator group on the destination computer too.

Filtering user accounts

The user account filter feature allows the user list to be filtered based on user groups, domains, or the date the account was created or accessed.

To filter user accounts

1. To open the filter dialog, click Filter from the Transplant Multiple Users page.

2. Filter the users using one of the following methods:

   To show users in one or more local groups
   - Select the User Groups check box.
   - Select Include or Exclude from the drop-down list.
   - Select the specific Local Groups for the users.
     The local group is included or excluded based on the selection in the drop-down list.

   To show users in one or more Domains
   - Select the Domains check box.
   - Select Include or Exclude from the drop-down list.
   - Select the specific Domain or workgroups for the users.
     The domain or workgroup is included or excluded based on the selection in the drop-down list.

   To show users based on the date the accounts were created or last accessed.
   - Select the Date check box.
   - Select one of the options from the drop-down list:
     accounts last accessed
     accounts not accessed
     accounts created
     accounts not created
Select values for a period of time (in the last specified days or months) or specify a date.

Note: You can enter any value between 0 to 999 in the In the last field.

After the filter options are selected, click OK.

The User Account list will add or remove any accounts that apply to the filter criteria. Only users that meet all selected criteria will be displayed. Example: If a local group is selected, and the Date option specifying accounts created in the last 7 days, only users in the specified local group that were created in the last 7 days will be displayed.

Orphan accounts and disconnected users

Orphan accounts are accounts that cannot be resolved by the local computer or domains available under Windows. The accounts are considered lost and can only be identified from the original users Security ID (SID) and remaining profile folder. PC Transplant can migrate the settings and the files associated with these accounts. Additional functionality allows a user to transfer these settings to a new account, the same account, or another existing account.

Disconnected users are user accounts that cannot be resolved due to the unavailability of their domain. Disconnected users can be easily identified because their icons are different from the icons used for other users. If the domain name of the disconnected user can be retrieved, then the user account is displayed with its domain name preceding it in this format - DomainName\UserName. Example: TestDomain\Joe. If the domain name of the disconnected user cannot be retrieved, then the user account is displayed with a question mark preceding it. Example: ?\Joe.

By including this additional functionality for disconnected users, PC Transplant no longer requires a network connection to migrate domain user accounts. This provides the added flexibility of using a network crossover cable to migrate users from one computer to another.

While deploying this user, the user account is created as a network user if its domain is not available. The settings of the user account are migrated to the newly created disconnected user. While deploying the package, disconnected users can be mapped to a new account, the same account, or another existing account.

Security Options

This section describes how PC Transplant migrates file and printer permissions. This feature is only available on Microsoft Windows using an NTFS file store.
Users and administrators of these systems are given the ability of managing the access of their files, folders, and printers at a group or user level. PC Transplant has the ability of migrating these permissions, allowing you to keep your files, folders, and printers secure.

When migrating the file and printer permissions, all security elements assigned to the file or printer are transferred to the destination computer. A security element may be a user group or an individual user account. If an element does not exist on the destination computer, it is added and will remain unresolved. The security element must already exist on the destination computer for the transfer to succeed. If a user uses Explorer to view the security of a migrated file (Properties, Security), any users or groups that do not exist on the destination computer are shown as an unresolved SID (user security identifier). In some cases, a domain user's FSID will migrate but remains unresolved until that user accesses that account either locally or across the network on the respective computer.

Potential problems exist with accessing files and printers migrated along with their security permissions if the user accounts assigned to the file or printer are local accounts or you are moving to a different domain. In these two cases, PC Transplant will turn off the migration of security permissions. You may choose to override the functionality when prompted during migration or if running in quiet mode using the -security option. If moving to a new domain, trust must be established between the old domain and the new one for the SID to be accepted or SID history must exist for the old SID.

**Personality build template options**

The PC Transplant Wizard uses template files (.PBT) to define what settings, files, and options are selected during run time. You can use predefined templates or create a template.

The following predefined templates are available:

- **Default** - Comprises of Desktop settings and a few Network settings such as the Folder/Driver share assignments, Dial-Up/RAS, and Windows drive mapping. No application, file, or data settings are captured by the Default.pbt.
- **DNA** - Comprises all Desktop, Network, and Application settings.
- **DNMail** - Comprises all Desktop, Network, Microsoft outlook, and Microsoft Outlook Express mail settings.
- **DNMSOffice** - Comprises all Desktop and Network settings, and all Microsoft Office applications settings.
- **DNMSApplication** - Comprises all Desktop and Network settings, and all Microsoft applications settings.
- **DNLotus** - Comprises all Desktop, Network, and Lotus application settings.

A template file can be selected from within the wizard or can be passed as a command-line switch to the program using the `-p` switch. The `-at: <template name>` command-line option lets you to specify the admin template filename when building a personality package. For a complete listing of what command-line options can be used to automate the creation of a personality package, see the *Altiris PC Transplant Reference Guide*.

By creating build templates, you can re-use settings when transplanting other personalities.

PC Transplant provides three ways to create a Personality Build Template:

- PC Transplant Wizard
- Template Builder
- Manually through a text editor

### PC Transplant wizard

Use the PC Transplant wizard to create the template.

**To create a template**

1. Run the wizard and select the settings you want.
   
   On the **Creating a Personality** screen of the wizard, you can choose to create a personality package, a Personality Build Template, or both.

2. To create a template file, select the **Save Personality build template** check box.

3. Specify the filename and location.

A template created using the PC Transplant Wizard is system dependant. It requires that all desktop, network, and application settings, files, and folders be present on the executing computer to define the template. To create a system independent template, see “**Template Builder**” on page 39.

### Template Builder

The Template Builder lets users build and edit templates outside the PC Transplant Wizard.

This tool allows a user to define a template without being on the source computer. The tool has an interface similar to the PC Transplant Wizard. The Template Builder can be started from the Windows start menu (**Start > Programs > Altiris**...
Transplanting PC’s Settings and Data

Personality Settings options

> PCTransplant > Tools > Template Builder or from the Tools menu of PC Transplant Editor.

For information, See “Using the Template Builder” on page 99.

Text editor

Template files can also be manually created using any text editor or program capable of creating text files. For information on template file formats, see the Altiris PC Transplant Reference Guide.

Computer settings options

Use the Desktop Settings, Network Settings, and Application Settings tabs to select the computer's settings you want to migrate.

The settings listed in the Desktop and Network tabs come from the information in the Dsktp*.ini and Ntwrk*.ini files. All of these files can be edited using a text editor. For information on Desktop and Network Settings File Format, see the Altiris PC Transplant Reference Guide.

The default settings are the settings that are configured in the build template file that you selected earlier.

For information, See “Personality build template options ” on page 38.

You can view the details and the warnings of the settings that you selected:

- If you selected Create a new Package or Edit an existing package in the wizard, then the warnings for the application settings are displayed with respect to the source version to all the possible versions.

- If you selected Real Time Migration, then the warnings for the application settings are displayed with respect to the source version and the destination version.

- For the Template Builder, the warnings for the application settings are displayed for all supported versions to all possible versions.

To view the details and warnings of the settings

1. Click the appropriate tab.
2. Select the item whose properties you want to view.
3. Click Properties.

The Properties page appears with the details and the warnings of the item that you selected.
Desktop settings

The settings listed in the Desktop tab come from the information in the Dsktp*.ini file. This file can be edited using a text editor. PC Transplant migrates properties under the following categories:

Control Panel:
- Accessibility
- Keyboard Settings
- Mouse Settings
- Power Settings
- Printer Settings
- Regional Settings
- Sound

Display Properties:
- Active Desktop
- Appearance
- Background
- Display Settings
- Effects (Plus! Settings)
- Screen Saver

Windows Shell:
- Desktop Icons
- Explorer Settings
- Taskbar

You can now distinguish between local and network printers. Under the Desktop > Control Panel > Printer Settings, you can view and select the group of printers that you want to migrate. By selecting one or both printer options and saving it in a template file, an administrator can control the migration of the group of printers.

You can also use the command-line option -desktop with the personality package. For information on the command-line options, see the Altiris PC Transplant Reference Guide. After migration, if the printer shortcut of an unmigrated printer is displayed on the desktop of the destination computer, you can use the following command-line switch to remove the shortcut. -noprintershortcuts
For information on command-line options, see the *Altiris PC Transplant Reference Guide*.

**Network settings**

The settings listed in the Network tab come from the information in the Ntwrk*.ini file. This file can be edited using a text editor.

PC Transplant can migrate the following properties:

- Computer and Domain Names
- Window drive mappings
- Folder/Drive share assignments
- Dial-up/RAS connections
- Netware Windows Client (Client 32) Settings
- TCP/IP Settings

When using multiple network cards in one computer, the user has the option of selecting the network card whose TCP/IP settings will be captured. This information is provided in the UI under TCP/IP for Network settings. On a destination computer, you can also remap one NIC to another.

---

**Note:** With the Template Builder, you cannot select multiple NICs. If you choose to migrate TCP/IP, then all the NICs are migrated.

You can migrate the computer and domain names through a personality package.

---

**Note:** To avoid conflicts, this option is not enabled during a real-time migration.

Before installing a personality package with a computer name or domain name on a destination computer, the source computer must be disconnected from the network. If the source computer is still connected to the domain, PC Transplant will not establish a trust relationship with the domain for the destination computer. Two computers using the same computer and domain names are not allowed by Microsoft. If PC Transplant cannot establish this trust, the destination computer is added to the ‘tmpwork’ Workgroup. To continue, you will then be forced to manually connect the destination computer to the domain.

**Computer Name.** A computer name migration requires that you be an administrator on both the source and destination computers. In the event that you are migrating a computer that is already added to a domain, you must also provide the user name and password of an account that has rights to change and
create a computer account in that domain. When a package with just the computer name is run on a destination computer, a dialog box asks you for this information. The dialog box appears only if the computer is currently a member of a domain. This is necessary because of the trust relationship that exists between the domain and that computer. PC Transplant associates the computer that is being migrated with the computer account on the domain. If the account is not correctly associated with the computer account on the domain, you cannot log on to any domain user accounts on that computer.

**Domain Name.** A domain name migration requires you to be an administrator on both the source and destination computers. Because of the nature of domain name migration, PC Transplant requires that you provide the user name and password of an account that has rights to change and create a computer account in that domain. You are prompted for this at the end of the PC Transplant Wizard when you click the OK button or the Schedule button. You may also pass in a -dau and -dap switch to specify this from the command line. In quiet mode the -dau and -dap switches are required for a domain migration to take place. For information about switches, see the *Altiris PC Transplant Reference Guide*.

User authentication for a domain is not stored in the template. The user name provided may need to be preceded by the domain name depending on the authentication model of your domain server. You can also pass an encrypted password in the command line.

For information, .

**Application settings**

The settings listed in the Application tab come from the .A2i files you have and the applications that are registered in the Windows registry as installed applications.

The list of applications in the Applications tab depends on the .A2i files you have and the applications that are registered in the Windows registry as installed applications. If the application is not registered in the registry, the application is still displayed if you had specified the complete path of the .EXE or complete or partial path with Type=Scan in the .A2i file.

The .A2i files are created for non-standard applications, that is, the applications that do not store their installation information with the registry.

For the PC Transplant Wizard, the applications that do not contain information in the registry are considered as if they are not installed. By default, these applications are not selected in the list. But if the Type=Scan tag is present in the .A2i for these applications, then these applications will be displayed in the list with a magnifying glass icon and a warning message. You can select such an application and when you click Finish to create a personality package, the target
computer is scanned. The path for the scanning is retrieved from its .A2i. If only
the application is found in the specified location, the application settings are
picked up for migration. If the applications are not found during the search, then
those applications are removed from the list.

During real-time migration, the actual scanning of the applications takes place
when you click the Finish button to start the migration. If the application is found
on both the source computer and the destination computer, then the application
settings are migrated. For information, see the *Altiris PC Transplant Reference
Guide*.

Altiris continues to add support for additional applications. The Application to
Information (.A2i) files which support these applications are available as a free
download from Altiris' Web site at ftp://ftp.altiris.com/pct/. Select the folder for
the version of PCT that you are using. For example, for version 6.8 use the ver6.8
folder. The ver6.x folder is for 6.x versions previous to 6.8.

**To update the .A2i files**

- From within the PC Transplant Editor, select **Help > Application Updates**.
  Your computer connects to the Altiris Web site, searches for new or updated
  .A2i files, and presents them for automatic download.

  Or,

  - Run the PC Transplant Wizard or the Template Builder.
  - Click the system menu, then **Update Application Support**.
    - The original files are placed in the Backup folder before updating the .A2i
      files.

    If you are using applications for which no .A2i files exist, PC Transplant ships
    with A2i Builder, a utility that lets you build your own custom .A2i files.

**Application install options**

You can use the Transplant Install Application page to select the application to
be installed on the destination computer. You can select to install the same or
higher version of the applications.

The Transplant Install Application page lets you define an application installation
file. You can select the applications and the corresponding version from the
Applications and Version Options list. The Version Options are the Highest Version
or Same Version for the Template Builder and the PC Transplant Wizard to create
a personality package. During real-time migration, the actual versions for the
particular application are displayed.

See “*Providing information for Application Installation* ” on page 45.
During real-time migration, some applications would require you to restart the computer after installation. In such cases, the Application Installer tool is launched to install other applications that you selected from the list, but only if you log on using the same user name.

When doing a real-time migration, you are shown information about the applications that are installed on both the source and destination computers. Applications that are installed on the source computer but not on the destination computer are designated so that you do not transplant settings for an application that does not exist on the destination computer. You are also shown information about the applications that are installed on each computer but are different versions.

Example: If Microsoft ActiveSync is installed on the source computer, but not on the destination computer, ActiveSync will be displayed in the application list, but it will be denoted as not being installed, and you will not be able to select settings for that application.

Note: This feature is not available for a real-time migration on the same computer.

For the Template Builder, this page appears if any applications are selected for migration. All the applications selected for migration are disabled initially. If the application installer definition file that you provided contains the install information and the install server information for the applications selected for migration, then the application list is enabled. The applications that are listed can be installed using the information defined in the Application Install Administrator.

Providing information for Application Installation

You can select the application to be installed and specify an installation file for the information on the installation. You can also create or edit the installation file using the Application Install Administrator tool.

To specify an .INI file

1. Click Browse.
2. Browse or enter the install definition file.
To select applications to be installed on the destination computer

1. From the Applications list, select the application.
2. From the Version Options list, click Highest Version or Same Version against the selected application.
3. Click Next.

You can also edit any of the install options defined in the Application Install Administrator.

To create an .INI file

◆ Click Define.

The Application Install Administrator tool is launched.

See “Providing information for Application Installation” on page 93.

Installation status

The installation status of an application can be viewed by clicking the Current State button in the PCTAppInstaller dialog box. Clicking this button displays the main application install and any additional installs it may have executed. To end an installation process, select it and click the End Process button. To view the latest state of the install processes being executed, click the Refresh button. If you end a parent install process, its child processes disappear from the PCTAppInstaller dialog box, although the child processes continue running on the destination computer.

Canceling the application's installation

You can cancel the application's setup while installing the applications. You can select to exit PC Transplant Application Installer only or to exit both the Application Installer and the Application Setup. After cancellation, if you are performing real-time migration the destination agent is launched to resume the migration.

Files, folders, and file types options

You can use the Transplant Source PC's Files and Folders page to include or exclude files to be migrated. You can select to include or exclude files based on criteria, such as filenames, folders, file types, drives, file size, and file date. The files, folders, and file types that are selected by default are the ones that are configured in the build template file that you selected earlier (step 3 on page 13).

See “Personality build template options” on page 38.
Add files, folders, or file types

You can add specific files, folders, or file types to migrate.

To add specific files

1. Click the Files tab.
2. Click Add New.
   
   A dialog box appears, providing two options to add a file. You can add one file from a specific path or you can specify a filename and add all files with that name from multiple paths.
3. In the File name field, enter a filename or browse to a file.
4. To add all files of the same filename, enter a filename and select the All files with these names check box in the Options pane.
5. Click Open.

To add specific folders

1. Click the Folders tab.
2. Click Add New.
   
   A dialog box appears, which lets you select the folders.
3. To add a folder in addition to the selected folder, type the complete folder path of the folder that you want to add.
   
   This folder gets added to the list of folders that you have already selected.
4. To include all the subfolders and the files of the selected folder, select the Include Subfolders check box.
   
   To only include the files of the selected folder, do not select Include Subfolders.

   **Note:** To exclude the files of the selected folder from migration, click Advanced to use the advanced options.

5. To include all folders that have the same name as the selected folder, select the All folders with this name check box.

To add specific file types

1. Click the File Types tab.
2. Click Add New.
   
   A dialog box appears letting you select a file type or create a custom type.
3 Select a file type from the list.

Or,

Click Custom to create a custom file type.

- In the dialog box that appears, type the extension in the File Type field.
- Type the description of the file type in the Description field.
- Click OK.

4 Click OK.

The file type is added to the list of the existing file types. The new file type is retained throughout.

You can use environment variables and wildcard characters while adding file, folder, or file type.

Delete files, folders, or file types

You can delete specific files, folders, or file types that you do not want to migrate.

To delete

1 Click the appropriate tab.

2 Select the files, folders, or file types that you want to remove from the list.

3 Click Remove or press DELETE.

When you have a list of files, folders, and file types, you can clear the check box for the ones that you do not want to migrate.

Exclude files, folders, or drives

You can exclude file types, files, folders, or drives through a Global Filter.

To exclude

- Click Filter from the Transplant Source PC's Files and Folders page.

For information on how the Global Filter works,

See “Filter files, folders, and drives” on page 61..

Prioritize files, folders, and file types to migrate

The Global Filter, along with each file, folder, or file type that you specify, constitutes a rule for migration. You can prioritize your rules to make sure you transplant only the items you want to migrate.
To prioritize
◆ To establish a priority of the included rules and Global Filter, click Prioritize.
See “Prioritize rules” on page 61.

Setting advanced options
The advanced options provide additional flexibility. Based on the type of file, folder, or file type you are working with, you can do one or more of the following:
■ Select specific files or file types from a folder to be included or excluded
■ Include files based on file size and date
■ Redirect files and folders to a new destination
■ Save all the transplanted data in a single folder or retain the same directory structure as on the source computer
■ Exclude drives, folders, subfolders, file types, or files

To configure advanced settings
1 Add a file, folder, or file type.
2 Select one or more items in the list.
3 Click Advanced.

To turn off/on advanced settings for a particular item
1 Select one or more items.
2 Right-click on the selected item.
3 Select Off to turn off the advanced settings.
Or,
Select On to turn the item back on.
You can specify the advanced options in the page that appears.
See “Advanced files settings” on page 49.
See “Advanced folders settings” on page 52.
See “Advanced file types settings” on page 56.

Advanced files settings
The advanced file options let you specify additional criteria and settings for individual files. You can use the multiple selections to edit the advanced options of a set of files. If you select multiple files, then the Multiple Files Advanced Options page appears.
If you select a single file, then the **File Advanced Options** page appears. The **File Advanced Options** page has three tabs: **General**, **File Filter**, and **Search**.

If you select multiple files and set their advanced options, then the options common to all the selected files are displayed in the **File Filter** tab. When multiple files are selected, the **Search** tab is not available.

### Advanced files settings - General Tab

You can specify the following criteria for the migration of the selected files.

**Table 4-1 General tab**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Destination</td>
<td>By default, if a file is migrated, it is migrated to the same path. You can specify a new path to migrate the files using the New Destination option. The destination field will be set to &lt;Multiple Selection&gt; if you had selected multiple files while choosing the Advanced option and if the New Destination field of individual files had been set to different file paths. Example: If you select to migrate the file C:\My Download Files\Index.html, you can choose to migrate it to a different path, such as C:\Web Pages. <strong>Note:</strong> For the Template Builder, you can provide a file and folder path that do not exist on the current computer. The PC Transplant Wizard that uses this Personality Build Template considers only those paths that exist on the current computer. You can use environment variables and wildcard characters with the New Destination option.</td>
</tr>
<tr>
<td>Size</td>
<td>You can establish criteria for whether the file must be migrated based on its size. You can select to have the file migrated only if it is larger or smaller than a specified size. Example: You may select to migrate a .ZIP file, but configure it so that it will be migrated only if it is less than 10 MB in size.</td>
</tr>
</tbody>
</table>
Table 4-1  General tab (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date</td>
<td>You can establish criteria for whether the file must be migrated based on its date. You can select to have the file migrated only if it was created, accessed, or modified within a certain time period. You can also specify the actual date as the criterion. Example: You may select to migrate a data file, but only if it was accessed in the last two months.</td>
</tr>
</tbody>
</table>

Advanced Files Settings - Exclude Tab

If a file is selected with All files with these names option or if the file path contains wildcard characters, you will have an additional tab called Exclude. On this page you have additional exclude functionality based on drives and folders. This tab is not available to a single file path containing no wildcard characters. It is also not available for multiple file selection if a single selected file does not relate to other files.

You have Excluded File Types, Excluded Folders, and Excluded Files areas where you have the list of excluded file types, folders, or files that you had specified. To add a new item to the list, click Add New in the corresponding area. The Excluded Folders area in the advanced option is disabled if the All files with these names option was cleared while adding files or the path does not have wildcard characters.

If you add invalid files or folders from this tab and click Apply or OK, then a dialog box appears with error details and the cause of the error. You can either delete the invalid item or go back and change the settings in the advanced options. You can use environment variables and wildcard characters with the options in the Exclude tab.

Advanced Files Settings - Search Tab

You can use the Search tab to view a list of all the files that meet the options that you have selected. You can sort files by file extensions or by the descriptive names of the file types. If you make changes to your options, make sure you click Apply before starting the search again. This tab is not available if multiple files are selected.

To search, click **Start** to search for the files that meet the options that you have selected. A search result appears.
You can find the items and the corresponding paths in the list. You can exclude the found items from the search result if required. Right-click the item you want to exclude.

You have the following options:

- Exclude File > This File
- Exclude File > All files with this name
- Exclude Parent Folder > with subfolders
- Exclude Parent Folder > without subfolders

If you exclude invalid files or folders and click Apply or OK, a dialog box appears with the error details and the cause for the error. You can either delete the invalid item or go back and change the settings in the advanced options.

**Advanced folders settings**

The advanced folders options let you specify additional criteria and settings for individual or multiple folders. You can use multiple selections to edit the advanced options of a set of folders. If you select multiple folders, then the **Multiple Folders Advanced Options** page appears.

If you select a single folder, then the **Folder Advanced Options** page appears.

The **Folder Advanced Options** page has three tabs: **General**, **Exclude**, and **Search**. If you select multiple folders and set their advanced options, then the options common to all the selected folders are displayed in the **Exclude** tab. When multiple folders are selected, the **Search** tab is not available.

**Advanced folder settings - General Tab**

You can specify the following criteria for the migration of the selected folders.
Table 4-2  General tab

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Include Files</td>
<td>Specify a single or multiple files contained in the folder using filenames or use a wildcard character (that is, <em>.txt, file</em>.txt, test?.doc) to indicate a specific file type. The filenames provided can be a file type (<em>.ext), file prefix (file.</em>), or a filename (file.ext). When defining a set of more than one type of file, separate each with a semicolon (;). The Include Files field is set to &lt;Multiple Selection&gt; if you have selected multiple folders while choosing the Advanced option, and the Include Files field of the individual folder has been set to different file types or names. You can use environment variables and wildcard characters with the Include Files option in the General tab.</td>
</tr>
</tbody>
</table>
Table 4-2  General tab (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>
| New Destination| By default, if a file or folder is migrated, it is migrated to the same path. You can specify a new path to migrate the files or folders by using the New Destination option. The destination field will be set to <Multiple Selection> if you have selected multiple folders while choosing the Advanced option and the New Destination field has been set to different file paths. Example: If you select to migrate the folder C:\My Download Files\Graphics, you can choose to migrate it to a different path, such as C:\Web Pages\Images.  
  
  Example: If you select to migrate the folder C:\My Download Files\Graphics, you can choose to migrate it to a different path, such as C:\Web Pages\Images.  
  
  **Note:** For the Template Builder, you can provide a file and folder path that do not exist on the current computer. The PC Transplant Wizard that uses such a Personality Build Template considers only those paths that exist on the current computer.  
  
  You can use environment variables and wildcard characters with the New Destination option.                                                                                                                                                                                                                       |
| Size           | You can establish criteria for whether files in a folder must be migrated based on their size. You can select to have the file migrated only if it is larger or smaller than a specified size.  
  
  Example: You may select to migrate a folder containing .ZIP files, but configure it so that files will be migrated only if they are each less than 10 MB in size.                                                                                                                                                                                                                   |
Table 4-2  General tab (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date</td>
<td>You can establish criteria for whether files must be migrated based on their date. You can select to migrate files only if they were created, accessed, or modified within a certain time period. Example: You may select to migrate a folder of data files, but only migrate the files that were accessed in the last two months.</td>
</tr>
</tbody>
</table>

**Advanced folder settings - Exclude Tab**

You can use the Exclude tab to exclude files of a certain file type, files in a subfolder, or specific file (example: you could select to migrate a personal data folder, but specify to exclude all .mp3 files). This tab is not available if there are no common subfolders for the multiple selected folders.

You have Exclude File Types, Exclude Subfolders, and Exclude Individual Files areas with the list of the file types, subfolders, and files that you have selected to be excluded. To add a new item to the list, click Add New in the corresponding area.

If you add invalid items in this tab and click Apply or OK, then a dialog box appears with error details and the cause of the error. You can either delete the invalid item or go back and change the settings in the advanced options.

You can use environment variables and wildcard characters with the options in the Exclude tab.

**Advanced folder settings - Search Tab**

You can use the Search tab to view a list of all the files and folders that meet the options that you have selected. You can sort files by file extensions or by the descriptive names of the file types.

If you make changes to your options, make sure you click Apply before starting the search again. This tab is not available when selecting multiple folders and setting advanced options.

To search, click **Start** to search for the files and folders that meet the options that you have selected. A search result appears. You can find the items and the corresponding paths in the list.

You can exclude the found items from the search result if required. Right-click the item you want to exclude.
You have the following options:

- Exclude File > This File
- Exclude File > All files with this name
- Exclude Parent Folder > with subfolders
- Exclude Parent Folder > without subfolders
- Exclude File Type of this File

If you exclude invalid items and click Apply or OK, then a dialog box appears with error details and the cause of the error. You can either delete the invalid item or go back and change the settings in the advanced options.

**Advanced file types settings**

The advanced file type options let you specify additional criteria and settings for individual or multiple file types. You can use the multiple selections to edit the advanced options of a set of file types. If you select multiple file types, then the Multiple File Types Advanced Options page appears.

If you select a single file type, then the FileType Advanced Options page appears.

The File type Advanced Options page has three tabs: General, Exclude, and Search. If you select multiple file types and set their advanced options, then the options common to all the selected file types are displayed in the Exclude tab. When multiple file types are selected, the Search tab is not available.

**Advanced file types settings - General Tab**

You can specify the following criteria for the migration of the selected folders.
<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Destination</td>
<td>Transplanting PC’s Settings and Data Personality Settings options</td>
</tr>
</tbody>
</table>
### Table 4-3  General tab (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>By default, if a file or folder is migrated, it is migrated to the same path. You can specify a new path to migrate the files or folders using the New Destination option. The destination field will be set to &lt;Multiple Selection&gt; if you have selected multiple file types while choosing the Advanced option and the New Destination field of individual file type has been set to different file paths. Example: If you select to migrate all *.xls files, you can choose to migrate them to a different path, such as C:\Data\Spreadsheets. If you are defining a new destination for file types, all files of that type are moved to the specified folder. Any duplicate file is distinguished by adding the identifier “duplicate (number) of filename” (Example: “duplicate (1) of mydocument.doc”). To keep the folder structure of the files found for that file type, use the Retain Folder Structure option. To include the drive letter from the original path, select the Include Drive Letter from Original Path check box. The Retain Folder Structure option is available only with folders and file types settings. Users have the ability to keep their folder structure in place when migrating specific file types. The Retain folder structure option is available from the File Types tab &gt; Advanced. When the Retain folder structure option is selected, all files of the type specified will be placed under the folder specified in the New Destination field followed by the original path of the file. Example: A .PDF file type is selected to be migrated and a new destination is specified as C:\PDF_Files. Also, suppose that the migration wizard finds the following file:</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>C:\Program Files\Adobe\Samples\help.pdf</td>
<td>With the Retain folder structure option selected, the file will be added to the following path: C:\PDF_Files\Program Files\Adobe\Samples\help.pdf. If the Retain folder structure option is not selected, the file will be simply placed in the folder indicated in the New Destination field. In the example above, the file would be migrated to the following path: C:\PDF_Files\help.pdf. If a help.pdf file already exists under C:\PDF_Files, the filename will change to indicate that it is a duplicate of the file that already exists. In the example above, the file becomes C:\PDF_Files\duplicate (1) of help.pdf. You can use environment variables and wildcard characters with the New Destination option.</td>
</tr>
<tr>
<td>Size</td>
<td>You can establish criteria for whether files must be migrated based on their size. You can select to have the files migrated only if they are larger or smaller than a specified size. Example: You may select to migrate all .ZIP files, but configure it so that files will be migrated only if they are each less than 10 MB in size.</td>
</tr>
<tr>
<td>Date</td>
<td>You can establish criteria for whether files must be migrated based on their date. You can select to migrate files only if they were created, accessed, or modified within a certain time period. Example: You may select to migrate all .XLS files, but only migrate the files that were accessed in the last two months.</td>
</tr>
</tbody>
</table>
Advanced file types settings - Exclude Tab

You can use the Exclude tab to include certain drives and/or folders while scanning a particular file type, and exclude other folders that reside within that search. You can also exclude individual file (example: you can select to migrate all .XLS files found under C:\, but exclude all .XLS files in C:\data\1997, and exclude all sample.xls files no matter where they are located). This tab is not available for multiple file type selection if a single file type is selected which does not relate to other file types.

You have Include Folders, Exclude Folders, and Exclude Individual Files areas with the list of the included folders, subfolders, and files that you have selected to be excluded. To add a new item to the list, click Add New in the corresponding area.

If you add invalid items in this tab and click Apply or OK, then a dialog box appears with error details and the cause of the error. You can either delete the invalid item or go back and change the settings in the advanced options. You can use wildcard characters with the options in the Exclude tab.

Advanced file types settings - Search Tab

You can use the Search tab to view a list of all the files that meet the options that you have selected. You can sort files by file extensions or by the descriptive names of the file types. If you make changes to your options, make sure you click Apply before starting the search again. This tab is not available when selecting multiple files and setting advanced options.

To search, click Start to search for the file types that meet the options that you have selected. A search result appears. You can find the items and the corresponding paths in the list. You can exclude the found items from the search result if required. Right-click the item you want to exclude.

You have the following options:
- Exclude File > This File
- Exclude File > All files with this name
- Exclude Parent Folder > with subfolders
- Exclude Parent Folder > without subfolders

If you exclude invalid items and click Apply or OK, then a dialog box appears with the error details and the cause of the error. You can either delete the invalid item or go back and change the settings in the advanced options.
Filter files, folders, and drives

You can exclude files, folders, and drives through the Global Filter feature. The File Filter, Folder Filter, and Drive Filter tabs each display a list of excluded default objects. For file and folder filters, you can select, clear, add, or delete items in the list. For drive filters, you can select or clear the items but cannot add a new item.

You can set the filter options from the Options tab:

- To include setting files in spite of any filters provided, select **Do not apply filters to settings files** from the **Setting Filter** area.
- To exclude profile folders of users who are not selected for migration, select **Do not search profile folders of non-selected users** from the **User Profile Folders** area.

**Note:** For Template Builder, you can add or delete a drive filter item.

To add a File or Folder to the Filter

1. From the **Transplant Source PC's Files and Folders** page, click **Filter**.
   
   The **File, Folder and Drive Filters** page appears.

2. To add specific files or folders to the **Global Filter**, click **Add New**.
   
   Follow the directions in the dialog box.

When you have a list of files, folders, and drives, you can select or clear the check box for the ones that you want to migrate.

Each selected item becomes part of the Global Filter. All items in the Global Filter will be excluded unless another rule is given a higher priority. For information about rules and priorities, See “**Prioritize rules**” on page 61.

Prioritize rules

The prioritize feature provides a method for managing the collection of individual files. When selecting which files to include or exclude, you can use filters and rules to manage which files to migrate. You can filter out specific files, folders, and drives through a Global Filter. You can also choose to include specific files, folders, and file types.

Each file, folder, or file type that you include (which is selected in the lists under the Files, Folders, and File Types tabs) is considered a unique rule for migrating files.

You can use the priority feature to determine which rule must take priority to resolve the conflict among the included rules and the Global Filter.
**Note:** If the Global Filter is changed from the highest priority, then PC Transplant scans for the files with higher priority than the Global Filter in all the drives that are excluded through the Global Filter. This would increase the package creation time.

Example of conflict between the included rules and the Global Filter:

Suppose you

- Exclude a folder named C:\Data in the Global Filter
- Include all .XLS files under the File Types tab

Suppose that the Global Filter has higher priority than *.xls file type. Then there is a conflict of rules if an .XLS file exists in the C:\Data folder. The include .XLS rule conflicts with a setting in the Global Filter. By using the prioritize feature, you can determine which rule gets a higher priority. If you give ".xls files" rule a higher priority than the Global Filter, then the .XLS file in the Data folder will be migrated, but all other files in the Data folder will not. If the Global Filter is given a higher priority than the ".xls files" rule, then the .XLS file in the Data folder will not be migrated, but all other .XLS files in other folders will be migrated.

Example of conflict among the different included rules:

Suppose you

- Include a file C:\a\a.txt
- Add a folder C:\a in the Folders
- Exclude C:\a\a.txt

If you give included file C:\a\a.txt higher priority than C:\a, then the file C:\a\a.txt will be picked up. If C:\a has higher priority than C:\a\a.txt, then C:\a\a.txt will be excluded from migration. If C:\a\a.txt is redirected, then C:\a\a.txt will be picked up irrespective of the priority to other files or folders unless the Global Filter excludes it.

To help you remember how each rule is configured, you can select a rule and click Properties. For files, folders, and file types, you can see if advanced settings were configured, and if so, what those settings are. For the Global Filter, you will be shown what files and folders have been excluded.

You can set the priority of a rule in the following ways:

- Select a rule and click **Set Priority**. You can then select to move the rule up or down in either an absolute or relative position.
- Select a rule and then click the up or down arrows.
- Select a rule and drag it up or down.
Capture options

From the Capture Options page, you can configure the following options:

- Spanning media
- Compression options
- Creating a self-extracting package
- Advanced options
- Migrating EFS encrypted files

Spanning media

The Spanning Media option lets you place a personality package on multiple drives or on multiple storage devices if the personality package size exceeds 2 GB or the specified span package size. You will be prompted to specify a new folder. When you select the new folder, the program continues.

Spanning works like this: Each spanned file follows the syntax package filename.###, where ### is a hex number starting from 001 (example: a package called install.exe that spanned over four files would also include an install.001, install.002, and install.003). When the package is executed, it will run until it needs the next file for spanning. You will then be prompted for the next file if it cannot be found.

To configure span options

1. Select the Span package check box.
2. Select a package size from the Size drop-down list.

Note: The range of values for Custom Size are from 10 to 2000 MB.

3. Define a name and path where you would like to save the personality package executable file.

   You can save your selections as a template for future use.

Compression options

You can disable compression for files that are migrated. You can disable compression for all files or you can specify individual files or file types. Removing compression for files that are already compressed can decrease the time required to migrate a file. Example: By default, PC Transplant compresses all of the Microsoft Outlook .PST files.
To disable compression for all files

1. Select **Disable compression for all files**.

2. In the Files pane, click **Add New** to add files for which the compression is to be disabled.
   
   Or,

   Select a file from the list and click **Remove** to enable compression.

3. In the File Types pane, click **Add New** to add file types.
   
   Or,

   Select a file type from the list and click **Remove** to enable compression.

4. Click **OK**.

Creating a self-extracting package

By default, the Create a self-extracting package (not recommended for Windows Vista) check box is selected for non-Windows Vista computers. If you select this check box for a Windows Vista computer, a .EXE file is created as the self-extracting package. If you do not select this check box for a Windows Vista computer, .EXE and .PKG files are created as the Personality Package. The .PKG file is not associated with PC Transplant. You have to use the .EXE file to run the .PKG file.

Migrating EFS encrypted files

EFS RAW lets you migrate encrypted files as they are. Using this option, you won’t lose any encryption. You can migrate the files, even if the user that is running PC Transplant doesn’t have the EFS certificate to open the files. You can capture EFS encrypted files in your user migration packages and then restore them to your target computers.

To migrate EFS encrypted files in their raw state

- Choose one of the following options:

  - On the command line, specify the **-efsraw** switch.
  
  - On the Capture Options page, select the **Enable raw migration of EFS encrypted files** box.

    When EFS files are captured in their raw state, you must export the EFS certificate to each user that wants to read the encrypted files after they are restored to the target computers.
To export the EFS certificate from the command line
1. On the source computer, ask the end user to log in.
2. Using the command line, execute the following command: `cipher /x`.
3. Enter a password to protect the exported certificate.

To export the EFS certificate from a graphical interface
1. Click `Start > Run`.
2. Run `certmgr.msc`.
3. In the Microsoft Management Console, click `Certificates > Current user > Personal > Certificates`.
4. Select the appropriate certificate.
5. Click `Action > All tasks > Export`.

To manually import the EFS certificate
1. On the target computer, ask the user to log in.
2. Double-click the certificate.
3. Follow the prompts to import the certificate.

To import the EFS certificate from a graphical interface
1. Click `Start > Run`.
2. Run `certmgr.msc`.
3. In the Microsoft Management Console, click `Certificates > Current user > Personal > Certificates`.
4. Select the appropriate certificate.
5. Click `Action > All tasks > Import`.

Advanced options
There are four tabs in the Options page: Paths, Undo, Security, and Other.

Environment variable support
You can type any valid combination of environment variables in the following manner:
- while including or excluding files, folders, or file types
- while adding files, folders, or file types from the Transplant Source PC's Files and Folders page
for the options in the File Filter tab of files and Exclude tab of folders
  
For information on Environment Variables, refer to the *PC Transplant Reference Guide*.

The environment variable is converted to a user-friendly description for the Template Builder (example: if you exclude C:\My Documents using the environment variable %MI_PERSONAL%, then it is converted to “My Documents” when it is displayed in the File Filter tab for files and the Exclude tab for the folders and file types).

The environment variable used with the New Destination option is kept as it is. If the path of the files or folders is given as the environment variable and the new destination is also given as the environment variable, then the new destination is resolved only for the current user. If the new destination path is only given as the environment variable, then it is resolved for all the users.

Example: if UserA, UserB, and UserC’s desktop folders are in C:\document and settings\user\Desktop and the user has defined a global filter of MI_DESKTOP, then no file is picked up from all the users’ desktop folders.

**Wildcard support**

You can type any valid combination of wildcard characters in the following manner:

- While including or excluding files, folders, or file types
- While adding files, folders, or file types from the Transplant Source PC's Files and Folders page
- For the options in the File Filter tab of files and Exclude tab of folders and file types

**Note:** For advanced files options, the filename when given with wildcard characters must be given within double quotes.

**Deploy options**

From the Deploy Options page, you can configure the following options:

- **Display options**
- **Advanced options**
<table>
<thead>
<tr>
<th>Option</th>
<th>What it Does</th>
</tr>
</thead>
<tbody>
<tr>
<td>Package Display</td>
<td>Configures the display options when the personality package is run.</td>
</tr>
<tr>
<td>Run Personality Package in quiet mode</td>
<td>Executes the personality package on the destination computer without any user intervention.</td>
</tr>
<tr>
<td>Run minimized</td>
<td>Executes the personality package as a background process.</td>
</tr>
<tr>
<td>Always replace</td>
<td>Always replaces the duplicate files on the target computer. This is the default option.</td>
</tr>
<tr>
<td>Older files with newer</td>
<td>Replaces older duplicate files with newer files when the personality package self-extracts.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> If you choose real-time migration to migrate the settings to the same computer, then the migration always replaces the older duplicate files with the newer files. All the options are disabled in this case.</td>
</tr>
<tr>
<td>Never replace</td>
<td>Never replaces the duplicate files on the target computer.</td>
</tr>
<tr>
<td>Prompt before replacing a file</td>
<td>Prompts the user before replacing any duplicate files.</td>
</tr>
</tbody>
</table>
Table 4-4  Deploy Options (continued)

<table>
<thead>
<tr>
<th>Option</th>
<th>What it Does</th>
</tr>
</thead>
<tbody>
<tr>
<td>Restart destination computer after the migration</td>
<td>Restarts the computer after the personality package finishes running or after the real-time migration is completed. This option is recommended for most personality packages to ensure that changes are made to the hard disk.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> By default, when you select this option, the destination computer is restarted. However, if you schedule and deploy a package using the Deployment Console on an active computer, the destination computer does not restart. PC Transplant does not restart a computer even if the Restart destination computer after the migration option is selected if a personality package is deployed using the Deployment Console.</td>
</tr>
<tr>
<td>Run/Edit Password</td>
<td>Password-protects the personality package so that users cannot run or edit it unless they know the password you have specified.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> This option is not applicable for Template Builder.</td>
</tr>
</tbody>
</table>

**Note:** For the File Replace transplant options, the migrated .INI files do not replace an existing .INI file on the destination computer. The settings of the .INI gathered on the source computer are merged into the .INI file on the destination computer.

**Display options**

The **Display Options** are also used for undo packages during real-time migration. The following display options are available when the personality package runs:

Table 4-5

<table>
<thead>
<tr>
<th>Option</th>
<th>What it Does</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Lets you type the phrase that should appear in the title bar of the installation dialog box. The picture to the right changes as you type the text.</td>
</tr>
</tbody>
</table>
Table 4-5  
(continued)

<table>
<thead>
<tr>
<th>Option</th>
<th>What it Does</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Lets you type an explanatory description (up to 256 characters) for the person who runs the personality package. Example: “This package installs all files and settings for an engineer. Call MIS at extension 22335.”</td>
</tr>
<tr>
<td>Background Bitmap</td>
<td>Specifies the image file that is used as the background image of the running personality package. You can use any bitmap file. You can also specify whether the image must be located in the upper-left corner, tiled, or stretched.</td>
</tr>
</tbody>
</table>

Select Upper left, Stretch, or Tile in the Properties. You can preview the display property that you have selected in the Preview field.

**Note:** Display options can be modified when using the **Real Time Migration** option to migrate your settings. While display options are not used during the real-time migration process, they can still be saved and included as part of the template.

**Package creation options**

From the Creating a Personality page, you can do the following:

- Save the personality package (not available when doing real-time migrations).
- Save the personality package to a Web server (not available when doing real-time migrations). For information, see Saving Personality Packages to a Web Server.
- Save the settings you configured as a Personality Build Template so that you can easily re-use the settings.
- Analyze the selections you made for the migration.
- Schedule the creation of a personality package (package creation only).
- Redirect the location to which the files, folders, and drives will be migrated (real-time migration only).
To build a personality package

1. Select **Build Personality Package**.
2. If you want to save the package locally or on UNC, select **Save package locally or on UNC**.

   Or,

   If you want to save the package on a Web server, select **Save package on web server**.
3. Define the name and path where you would like to save the personality package executable file in the **Save as** field.

   You can save your selections as a template to use again in the future.

To create a Personality build template

1. Select **Save Personality Build Template**.
2. Specify the name and path in the **Save as** field.

   See “Personality build template options” on page 38.

**Analyze**

When you have selected all the settings and files that you want to migrate, you can analyze your selections before creating the personality package or performing the real-time migration.

The analysis generates a report that contains the following information:

- Source computer name
- Total uncompressed size of the migration data
- Total number of distinct files
- Estimated time
- Path and names of files that will be migrated
- Detail showing files that will be migrated

To analyze your selections

1. Click **Start** from the **Personality Analysis** page.

   When the analysis is complete, the **Analysis Report** appears. The report has two tabs: **Summary** and **Details**.

2. In the **Summary** tab, click **Open Summary** to open the summary with Notepad application.

   You can save the report if required.
To filter the items listed on the Details tab, click **Filter**.

Specify the criteria for the filename, date, and size.

Click **OK** to view the filtered list.

**Note:** The filter does not apply to the actual migration.

In the Details tab, click **View Detail** to open the details with Notepad application.

You can save the report if required

### Schedule

You can schedule the PC Transplant Wizard to create a personality package on a certain day and time or on a configured interval. At the scheduled time, the PC Transplant Wizard runs in quiet mode, meaning there is no displayed interface or user intervention, collecting your defined migration options. There is no displayed interface or user intervention when a build occurs through the scheduler.

In quiet mode, if the disk space is insufficient then the migration stops. If a package exists in the location, it is replaced.

The only indication that the migration is running is an icon displayed in the system tray of the task bar. Place your mouse cursor over the icon to obtain the progress of the migration.

For information on running the PC Transplant Wizard in quiet mode, see the **Altiris PC Transplant Reference Guide**.

**To schedule the creation of a Personality Package**

1. From the **Creating a Personality** page, click **Schedule**.
   
   The **PCTWizard_Task** page appears with two tabs: **Schedule** and **Settings**.

2. Select the frequency of the task from the **Schedule Task** drop-down list.

3. Set the required criteria.

4. Select the start time.

5. (Optional) Click **Advanced** to configure an end date and the settings to repeat the task.

6. (Optional) Select the **Schedule Task Daily**.

7. Select **Show multiple schedules** to configure multiple schedules for the task.
8 (Optional) Click the Settings tab to configure additional task settings, idle time, and power management settings.

For information on using the scheduler, see Microsoft’s Task Scheduler in the Microsoft Windows help.

9 When the task has been configured, click OK.

10 From the Creating a Personality page, click OK.

The task is now scheduled and the personality package will be built at the scheduled time.

Redirect

When doing a real-time migration, you can change the destination path of files or folders of a category or any of its sub-items. You can also choose to redirect the location to which the drives, folders, and files must be migrated. Example: you can redirect all files on drive C on the source computer to drive D on the destination computer. You can use the Drives and Folders tab to redirect folders and files to different locations.

Note: Redirection of a folder will override any drive redirection definitions, and redirection of a file will override folder and drive redirection definitions.

If you have changed the destination of any files, select the Enable Safe Migration check box to transplant operating system files to their required folders. Destination changes will not take effect for shell folders, profile directories, and operating system specific directories, unless specified by the user by clearing the Enable Safe Migration box. The "Total Required Space" appears, showing the amount of disk space required for each drive based on the user’s selections.

To allow the migration of the files to the network drives, select the Allow Migration on Mapped Network Drives check box. You can also use -netdrives command-line option to do this. For information on command-line options, see the Altiris PC Transplant Reference Guide.

To redirect a single file to a different location

1 Click the Folders tab.

2 Under Source, browse for the file to be migrated.

3 Select the file you want to redirect.

4 Click Redirect.

5 Enter or browse to the new location.

6 Click OK.
Saving personality packages to a web server

You can save a personality package to a Web server using the PC Transplant Web Store agent. The PC Transplant Web Store is a Web extension that runs on Microsoft's Internet Information Services (IIS). Using PC Transplant, you can build personality packages on a Web server requiring only an Internet connection for the source computer.

A new UI option has simplified the package storage management. Packages are now stored in `<PCTwebPath>/PCTPackages/<UserSpecifiedPath>`. Example: `<MyWebServer>/PCTPackages/<Sales/1.exe>`. If a package already exists at the server, then you are prompted with a file replace message. You do not need to refer to the summary log to locate the package later.

If you save the personality package on Webstore, you can run the .EXE file from Web Store on the destination computer. But you need to download the .PKG file and then run it on the destination computer.

To install the Web Store agent on a Web server

1. Copy PCTWeb.exe to the Web server (running IIS) that you want to install it on.

   This file is located at `\<folder where PC Transplant is installed>\Solution\PCTWeb.exe`.

2. Run PCTWeb.exe and follow the directions in the install wizard.

You can use the Web Store to save packages.

If you do not provide a name for the package, then the package is saved as `computer_name_month_dd_yyyy_hh-mm-ss.exe`. If you want more control over the location and name of the personality package, enter the subfolder and filename. Example: if you want to save a package named MyPackage.exe to a folder named MyPCTFolder on a Web server named MyWebServer, type the following:

MyWebServer in the Server box and MyPCTFolder/MyPackage.exe in the Path box.

The path can also be set by using the build filename option (-f) to specify your own custom build location. This option can be combined with the quiet option (-q or -qm) to automate the process. For information on command-line options, see the Altiris PC Transplant Reference Guide.

To validate that the PC Transplant Web Store agent is installed and functioning properly, type `http://<servername>/pctweb/pctweb.dll` in the address field of your Web browser. If the agent is successfully located, you will see the amount of free disk space available on the Web server.

You can delete packages on a Web Store.
To delete any package on the Web server, a user can type the following command from the Web browser:


To delete the package created, type the following command into the address field of a Web browser:


Skip Files options

While a personality package is being created, or during a real-time migration, you can skip the file that is being migrated. When you click **Skip**, the transplant is paused. You can skip the current file or skip other files of that type.

If you click **Skip This File**, you will be shown the filename and path. The file will be identified as a data file or a setting file. If it is a setting file, you will also see its settings category. You are given a warning that skipping this file may not migrate settings for that category properly. You must confirm whether you want to skip the file or not.

If you click **Advanced**, you will be shown the filename and path. The file will be identified as a data file or a setting file. You are given the option to skip all files of that type from the current folder. If it is a data file, you can also skip all remaining files of that type. If it is a setting file, you are given a warning that skipping this file may not migrate settings for that category properly. You must confirm whether you want to skip the file or not.

Cancelling the migration

Click **Cancel** to be prompted to run the rollback file if you had enabled the undo creation from the Advanced Options page. The undo package rolls back the settings migrated till that point.

**Note:** In real-time mode, if you cancel the migration when the settings are being migrated, then you are prompted to run the rollback. If you click Yes, then all the migrated settings are rolled back. If you click No, PC Transplant rolls back the settings that are not completely migrated on the destination computer in quiet minimized mode. This is done to avoid the instability to the system caused by the incompletely migrated settings.
Cleaning up source files

You can use a Cleanup Package to remove any private or personal files on the source computer after migrating a computer personality from a source computer to a target computer. A shortcut for the Cleanup Package is placed on the desktop of the source computer. After creating a personality package and completing the migration to the target computer, run the Cleanup Package on the source computer. The cleanup package file is named as Clean Up personality package name.exe.

By default, the Cleanup Package file is created in the following folder of the currently logged on user's profile:

```
Local Settings\Application Data\Altiris\PC Transplant\version for NTx users
```

Note: You cannot control what files the Cleanup Package removes.

To clean up source files

1. Double-click the **Cleanup Package** shortcut from the desktop.

   Or,

   Execute the **Cleanup Package** file from the default location.

   The **Altiris Personality Clean Up Wizard** helps you with the clean-up process. You can find the package information on the **Welcome** page.

2. Click **Next** to select the items you want to remove.

3. Click **Begin** to start the clean-up process or **Cancel** to quit the process.

4. If you had removed the items, select **Restart the computer** for the migration to take effect.

5. Click **Finish**.

Examples of files that are removed.

On the **Transplant PC's Settings** page, if you select associated files underneath an application (compare with an application's file type), those files are removed. Similarly, any files added in the wizard by filename, folder, or file type are removed by a Cleanup Package.

Example: The user selects to transplant all the .mp3 music files. If cleanup is turned on, the cleanup deletes all transplanted .mp3 files on the source computer. If the user selects to transplant a folder called "Stuff from Home", all files in that folder are included in the clean up. If a user selects to transplant a single file called Work Log.txt, it is included in the clean up.
Examples of files or extensions that are not removed. The following are NOT removed by a Cleanup Package: pagefile.sys, ntuser.dat, ntuser.da0, ntuser.dat.log, win386.swp, 386spart.par, user.dat, user.da0, system.dat, system.da0, shelliconcache, msdos.sys, autoexec.bat, config.sys, *.exe, *.dll, *.bat, *.sys, *.dat, *.da0, *.swp, *.fon, and *.ttf files.

Password encryption utility

You can pass any string to the Password Encryption tool to get it converted to an encrypted string.

To encrypt a password and use it

1. To open the Password Encryption utility, select Start > Programs > Altiris > PCTransplant > Tools > Password Encryption Utility.

2. In the Actual Password field, type the string that you want to encrypt.

3. Click Encrypt.

   The encrypted password appears in the Encrypted Password field.

4. Click Copy to copy the encrypted password.

   You can now paste the encrypted password anywhere.

5. Click Exit.

   The encrypted string can be passed with the command-line options that accept passwords. A new switch -DecryptPwd is also included. -DecryptPwd must be passed when using encrypted passwords from the command line. This switch decrypts all the encrypted passwords provided from the command line. You cannot use encrypted and unencrypted passwords together with a command-line option. For information on command-line options, see the Altiris PC Transplant Reference Guide.

Viewing, printing, or changing personality package contents

PC Transplant includes tools that let you view, print, or change the contents of a personality package.

The Package Contents tool outputs the contents of a personality package to a file that can be viewed and printed. The file includes information such as the package version, title, description, computer it was built on and its domain, who built the package, a summary of its contents, and detailed information regarding files and registry values.
You can start the Package Contents tool (Pkgcntnt.exe) on the shared network device.

**To run the Package Contents tool**

- If you have installed PC Transplant on the local computer, select Start > Programs > Altiris > PCTransplant > Tools > Package Content to run the tool.

  Or,

  From the PC Transplant Package Editor, select Tools > Package Report.

  For information, See “About using the PC Transplant Package Editor” on page 119.

**To view the package contents**

1. Open the **Package Contents** tool.
2. Select **Registry** to get the report of all the registries contained in the package.
3. Select **Files** to get the report of all the files contained in the package.
4. In the **Package File** field, browse for a package file.
5. In the **Output File** field, name the output file.

   By default, the output file, contents.log, is saved in the PC Transplant installation folder.
6. Click **OK**.

   A dialog box appears when the contents file is generated successfully.
7. Click **Yes** to view the contents file in the Notepad application.
8. Click **Close**.

You can change a personality package by using the PC Transplant Package Editor to delete, add, and edit individual files or registry values.

See “About using the PC Transplant Package Editor” on page 119.

You can also use the PC Transplant Wizard to add, delete, or modify package settings. Simply start the PC Transplant Wizard, select **Edit an existing package**, and make your changes in the wizard as if you were creating a new package.
Transplanting PC's Settings and Data

Viewing, printing, or changing personality package contents
Installing Personality Package

The personality package is a wizard-based self-extracting executable file. You can distribute a personality package by floppy disk, e-mail, network share, CD, or Web download. You can also deploy personality packages using Altiris® Deployment Solution™ software, a total computer management and deployment solution. In Windows Vista, the executable file is not self-extracting.

A personality package is created by selecting the option to create a self-extracting package in PCTWiz. By default, on the Capture Options page in the PC Transplant Wizard, the Create a self-extracting package (not recommended for Windows Vista) check box is selected for non-Vista computers. If you select this check box for a Windows Vista computer, a .EXE file is created as the self-extracting package. If you do not select this check box for a Windows Vista computer, .EXE and .PKG files are created as the self-extracting package. A .PKG file includes settings, files, folders, and registry information. A .EXE file is the capture logic that is copied to the path specified by the user and is renamed to the name provided by the user. The .PKG file is not associated with PC Transplant. You have to use the .EXE file to run the .PKG file.
To open a personality package

1. Browse to the location where you saved the personality package.
2. To open, double-click the executable file from the target computer. The wizard opens with a Welcome page that gives you the general information about the personality package. The details on creation time, computer name, domain name, and the user who created the Package are displayed.

See “Deploying a Personality Package” on page 22.

Installing summary and log details

After the personality is migrated, a log screen appears. The Log details provide information about the migration. The warning are displayed for the settings that you selected in the migrate the .log file with respect to the version or platform in the plaform. You can view three levels of log details.

See “Viewing the PC settings and data options” on page 86.

To view the log details

1. In the Error Level drop-down list, select Errors to view the errors and general messages.
2. All the errors appear in the right pane. From the left pane, expand the tree structure and browse to the particular category to see the error messages.
3. From the left pane, click the warning icon to view the error messages.
4. In the Error Level drop-down list, select Errors and Warnings to view the errors, warning, and general messages.
5. All the errors appear in the right pane. From the left pane, expand the tree structure and browse to the particular category to see the error messages or the warning messages. From the left pane:
   - Click the warning icon (the red X sign) to view the error messages.
   - Click the caution icon (the yellow exclamation sign) to view the warning messages.
6. In the Error Level drop down list, select All Messages to view all the messages.

All the errors, warnings, and the detailed information on the errors that occurred appear in the right pane. From the left pane, you can expand the tree structure and browse to the particular category to view the error messages, warning messages, or detailed information. From the left pane:
   - Click the warning icon (the red X sign) to view the error messages.
Click the caution icon (the yellow exclamation sign) to view the error messages.

Click the detailed information icon to view the detailed information.

7 Click **Back** to redefine settings, if there is a problem.

From the Log Report page, you can click Back to redefine or change the settings if there is a problem that you find after simulation. This is not possible after the actual migration.

See “Performing actual migration after simulation” on page 81.

By default, the summary and the migration details for the currently logged on user are saved in the migrate.log file in the following folders: \Local Settings\Application Data\Altiris\PC Transplant\version for NTx users. You can change the default path where the summary and the migration details are saved by using the -migratelog command-line option.

For information on command-line options, refer to the *Altiris PC Transplant Reference Guide*.

---

**Performing actual migration after simulation**

The Personality Migration Wizard prompts you to start the real migration if you had simulated the migration process. You can migrate the personality with the options and settings that you have chosen.

To *start migration with the selected settings and options:*

1. Select **Use the options provided during simulation** check box.
2. Click **Next** to start the migration.

---

**Personality Settings options**

You can modify the settings that were captured while creating the personality package. You can easily configure these settings in the Personality Migration Wizard.

See “Selecting a user and creating new accounts” on page 82.

See “Viewing the PC settings and data options” on page 86.

See “Using application installation options” on page 88.

See “About configurable options” on page 89.
Selecting a user and creating new accounts

The personality package has the ability of transplanting files and settings for a single user, multiple users, or all users.

See “Security Options” on page 37.

The wizard displays all user accounts available on the destination computer. From this page, select the destination user.

When selecting which user accounts to migrate, you are shown the user accounts that exist on both the source and destination computers. You can map the settings of one user account on the source computer to any account name on the destination computer. You can use the -usermap command-line option to perform the same action.

For information on command-line options and the user map file, refer to the Altiris PC Transplant Reference Guide.

To select the destination user

1. Click the Destination column. A drop-down list appears with the user accounts on the destination computer.

2. Select a destination user from the list. All guest accounts and those accounts that have never been logged on to the computer are filtered from this list.

User Creation

You can also create new accounts on the destination computer to match accounts on the source computer. Consider a scenario where an account named Bob exists on the source computer, but not on the destination computer, and you want to migrate that account and maintain the name. In this case, you can create an account named Bob on the destination computer from the wizard, and then select that account to be migrated. Only users with administrative rights have the ability to view and migrate multiple users. If the current user running the wizard does not have administrative or system rights, then the user can migrate the settings to the current user's computer only if the user is listed in the source user's list.

The package determines if the user executing the package has administrative rights. If the user is not an administrator, then it checks to see if the user's settings are included in the package. The user is not allowed to proceed unless the user's settings are found and the user is only allowed to migrate the user's settings. If the user has administrative rights, the package checks the accounts in the package with the accounts on the destination computer. The user can create accounts in the package that do not exist on the local domain. The user is also given the option of creating any additional user accounts. The accounts can also be created if the user has mapped them through the command line or with the help of the user map file. The user mapping can be done with the -user and -usermap command-line options also. For information, see the Altiris PC Transplant Reference Guide.
While creating new user accounts and adding them to a particular group on the destination computer, you need to verify whether the user account is already a member of the group. If the user account is not an existing member of the group, then the user account is added to the group. Example: If a domain user, Altiris\Joe, exists on the source computer and is a member of the administrator group on the source computer, then Altiris\Joe should become a member of the administrator group on the destination computer too.

To create new accounts

1. From the Transplant Multiple Users page, click Create. The Create Account page appears with the list of the accounts that do not exist on the destination computer. These accounts were chosen at the time of creating the package from the source computer.

2. Select one or more user accounts from the list. The selected accounts will be created.

3. If you want to create a new account, click Add New. The Add New User page appears.
   a. Type the user name in the User name box.
   b. Select the domain from the Domain box.
   c. Select the group from the Groups box.
   d. To create a new group, click Add New from the Add New User page.

4. To modify the user accounts that must be created, click Edit. The Edit User page appears.
5 In the **New User Password** field, type the password that you want to use. The password is applied only to the local users. PC Transplant attempts to set an empty password for the new account. If your computer is a member of a domain that restricts a password to a minimum length or complexity, PC Transplant creates the password using the following syntax: PasswordMMYYYY The syntax is case-sensitive, where MM represents the number of the month and YYYY represents the year the account was created. The password is logged in the migrate.log file. You can override the password defined by the wizard by using the New User Password option provided in the Personality Migration Wizard or through the -newuserpassword command-line option. The new password must satisfy the password policy on the local computer. Only one password can be set for all the local users, that is, you cannot change this password for the other new users you want to create. For information on command-line options, see the *Altiris PC Transplant Reference Guide*. 6.

6 Click **OK**. When accounts have been validated, you are provided with a user map to link user accounts from the package with accounts on the destination. The user mapping can also be done with the -user and -usermap command-line options.

### About orphan accounts and disconnected users

Orphan accounts are accounts that cannot be resolved by the local computer or domains available under Windows. The accounts are considered lost and can only be identified from the original users Security ID (SID), and remaining profile folder. PC Transplant has the ability of migrating the files associated with these accounts. Additional functionality allows users to transfer these settings to a new account, same account, or another existing account.

Disconnected users are user accounts that cannot be resolved due to the unavailability of their domain.Disconnected users can be easily identified because their icon is different from the icons used for other users. If the domain name of the disconnected user can be retrieved, then the user account is displayed with its domain name preceding it in this format - DomainName\UserName. Example: TestDomain\Joe. If the domain name of the disconnected user cannot be retrieved, then the user account is displayed with a question mark preceding it. Example: ?\Joe.

By including this additional functionality for disconnected users, PC Transplant no longer requires a network connection to migrate domain user accounts. This opens up the added flexibility of using a network crossover cable to migrate users from one computer to another.
While deploying this user, the user account is created as a network user if its domain is not available. The settings of the user account are migrated to the newly created disconnected user. While deploying the package, disconnected users can be mapped to a new account, same account, or another existing account.

About migration of computer name and domain name

You can migrate the computer and domain name through a personality package. Before installing a personality package with a computer name or domain name on a destination computer, the source computer must be disconnected from the network. If the source computer is still connected to the domain, PC Transplant will not establish a trust relationship with the domain for the destination computer. Two computers using the same computer and domain names are not allowed by Microsoft. If PC Transplant cannot establish this trust, the destination computer is added to the `tmpwork` Workgroup. You will then be forced to manually connect the destination computer to the domain to continue.

The computer name and domain name migration requires you to restart the computer. The migration of the other settings take place after the computer is restarted. Windows NTx computers have auto-logon support.

**Computer Name**

A computer name migration requires that you be an administrator on both the source and destination computers. In the event that you are migrating a computer that is already added to a domain, you must also provide the user name and password of an account that has rights to change and create a computer account in that domain. When a package with just the computer name is run on a destination computer, a dialog box asks you for this information. The dialog box appears only if the computer is currently a member of a domain. This is necessary because of the trust relationship that exists between the domain and that computer. PC Transplant associates the computer that is being migrated with the computer account on the domain. If the account is not correctly associated with the computer account on the domain, you cannot log on to any domain user accounts on that computer.

**Domain Name**

A domain name migration requires you to be an administrator on both the source and destination computers. Because of the nature of domain name migration, PC Transplant requires that you provide the user name and password of an account that has rights to change and create a computer account in that domain.

You may also pass in a -dau and -dap switch to specify this from the command line. In quiet mode the -dau and -dap switches are required for a domain migration to take place. For information about switches, see the *Altiris PC Transplant Reference Guide*. User authentication for a domain is not stored in the template.
The user name and password provided may need to be preceded by the domain name depending on the authentication model of your domain server.

**Viewing the PC settings and data options**

You can transplant the desktop, network, and application settings. You can also transplant the files, folders, and file types that were captured during the personality package creation. Select the computer's settings and data you want to migrate from the Transplant Settings and Data page.

The values are given for the space required to install settings and data to a drive and the amount of free disk space available on the drive. You need to free up additional space on an existing drive to make room for the migration. When the files have been removed, click the Free Space column to recalculate the amount of free space available.

The details and the warnings of the settings that you selected can be viewed. The warnings for the application settings are displayed with respect to the source version and the destination version.

**To view the details and warnings of the settings**

1. Select the item whose properties you want to view.
2. Click **Properties**.

   The **Properties** page opens with the details and the warnings of the item that you selected. You can set the advanced migration options from the **Transplant Settings and Data** page.

**To set the advanced migration options**

- Click **Advanced** to set the advanced migration options.

   The **Advanced Migration Options** page appears.

   See “**Advanced Migration Options**” on page 86.

**Advanced Migration Options**

You can migrate the drives, folders, and the network cards. There are three tabs in the **Advanced Migration Options** page: **Drives**, **Folders**, and **Network Cards**.

**Redirection**

The user also has the opportunity to redirect drives and folders. The user can change the destination of a category or any of its sub-items using the Advanced button.
If you selected to migrate TCP/IP settings for multiple network cards, the **Advanced Migration Options** page lets you redirect these settings. PC Transplant attempts to select a logical match for the source and destination computers, but may not be successful when dealing with different network cards or the number of cards on the destination computer.

If you have changed the destination of any files, select the **Enable Safe Migration** check box to transplant operating system files to their required folders. Destination changes will not take effect for shell folders, profiles directories, and operating system specific directories, unless specified by the user by disabling the **Enable Safe Migration** box.

To allow the migration of the files to the network drives, select the Allow Migration on Mapped Network Drives check box. You can also use -netdrives command-line option to do this. See the *Altiris PC Transplant Reference Guide*.

You can also choose to redirect the location to which the drives, folders, and files must be migrated. Example: you can redirect all files on drive C on the source computer to drive D on the destination computer. You can use the Drives tab to redirect directories and files to different locations.

**To redirect a single file to a different location**

1. From the **Transplant Settings and Data page**, click **Advanced**.
2. Click the **Folders** tab.
3. Under **Source**, browse for the file to be migrated.
4. Select the file you want to redirect.
5. Click **Redirect**.
6. Enter or browse to the new location.
7. Click **OK**.

**To redirect a network card’s settings to a different location**

1. From the **Transplant Settings and Data page**, click **Advanced**.
2. Click the **Network Cards** tab.
3. Under **Source**, select the network card settings you want to migrate.
4. Click the network card drop-down under the **Destination** tab.
5. Select a different card.
6. Click **OK**.
Using application installation options

The **Transplant Install Application** page lets you define an application installation file. You can select the applications and the corresponding version from the **Applications** and **Version Options** list. The applications that are listed can be installed using the information defined in the Application Install Administrator. You can also edit any of the install options defined in the Application Install Administrator. To edit the install options, click Define from the Transplant Install Application page. This lets you edit the properties of the selected applications stored in the package that you set in the **Install Properties** page with the Application Install Administrator tool.

Some applications would require you to restart the computer after installation. In such cases, the Application Installer tool is launched to install other applications that you selected from the list, but only if you log on using the same user name.

If the application of the same version already exists on the destination computer, then it is not installed. **Application Already Installed** is displayed in the **Version Options** list against the application.

**To specify an .INI file**

1. Click **Browse**
2. Browse or enter the install definition file

**To select applications to be installed**

1. Select the applications from the **Applications** list
2. Click **Highest Version** or **Same Version** from the **Version Options** list against the selected application.

You can also edit any of the install options defined in the **Application Install Administrator**.

**To edit an .INI file**

1. Click **Define**.
2. The **Install Properties** page appears.

   See “**Providing information for Application Installation**” on page 93.

**Installation Status**

The installation status of an application can be viewed by clicking the **Current State** button in the PCTAppInstaller dialog box. Clicking this button displays the main application install and any additional installs it may have executed. To end an installation process, select it and click the **End Process** button. To view the latest state of the install processes being executed, click the **Refresh** button. If
you end a parent install process, its child processes disappear from the PCTAppInstaller dialog box, although the child processes continue running on the destination computer.

About cancellation of application installation

You can cancel the application's setup while installing the applications. You can choose to exit PC Transplant Application Installer only or to exit both the Application Installer and the Application Setup. After cancellation, the Personality Migration Wizard gets launched to continue the migration.

Migration support for non-standard applications

You can cancel the application's setup while installing the applications. You can choose to exit PC Transplant Application Installer only or to exit both the Application Installer and the Application Setup. After cancellation, the Personality Migration Wizard gets launched to continue the migration.

About complete installation support

If you had captured certain applications that support complete installation, then even if the application is not installed on the destination computer, the settings are migrated with the application. The applications that support complete installation presently are:

- AOL Instant Messenger
- AT & T Global Network
- Palm Desktop Application
- WinZip

About configurable options

You can modify the options to install the personality package or to simulate the personality package installation.

Migrating security permissions

You can migrate the security permissions for the files or folders that you had captured. You also have the option of propagating the file security to its parent folder. The users and administrators of Microsoft Windows using an NTFS file store can migrate the access of their files and folders at a group level or user level. Thus, you can keep your files and folders secure.

See “Security Options” on page 37.
To migrate the security permissions

1. To migrate the security permission for files or folders, select the **Migrate Security Permission** check box.

2. To propagate the read-only file security permission to the parent folder, select the **Propagate Read Permission to Parent** check box.

Creating undo package

You can choose to create an undo package of the migration. You can also create a shortcut for the undo package on the desktop. You can also use `-nu` and `-noundoshortcut` command-line options to do this. For information on command-line options, see the *Altiris PC Transplant Reference Guide*.

To create an undo package

- To create an undo package of the migration, select the **Create an Undo Package for those settings and files migrated** check box from the **Transplant Options** page.

Simulating a package installation

This feature allows a user to execute a package on a computer in "simulation mode." The package executes and imitates a migration without actually making changes to the user's local registry or files.

A report appears after the simulation completes. You can specify the path of the `simulate.log` file and generate the simulation report.

Use the information to determine if there are missing applications, incompatibilities, and so on. Any error can be fixed prior to running the package in a production environment. Simulation can also be automated using the `-simulate` command-line option. For information on command-line options, see the *Altiris PC Transplant Reference Guide*.

To simulate the package installation

1. Select the **Simulate the migration and get report of any potential errors** check box.

2. The **Simulating Personality Migration** page appears and the migration is simulated.

Migrating the Personality

The actual migration can be resumed after the simulation is complete, if you had chosen to simulate. For the actual migration, you can use the same settings that you had selected during the simulation.
Personality package installation complete

When the installation completes, depending on the selections that you had made, you may:

- Log off the current user
- Restart your computer
- Do nothing

You can then check the settings. If you are not satisfied with the migration, execute the Undo package if you had selected the **Create an undo package during the migration** check box at the time of migration. The shortcut of the Undo package is placed on the desktop. The changes made by the personality package are undone. If the changes are acceptable, then you may delete the Undo file. If you undo the complete migration, then the Undo package is deleted automatically.

See “**Personality Rollback**” on page 91.

**Personality Rollback**

If you are not satisfied with the migration, you can execute the Undo package that you selected to create at the time of migration. By default, the Undo package file (Package-rb.exe) is created in the following folder in the user’s profile:

```
Local Settings\Application Data\Altiris\PC Transplant\version for NTx users
```

To undo the changes made by a personality package

1. Double-click the Undo Package shortcut from the desktop or Execute the Package-rb.exe from the default location. The Altiris Personality Rollback Wizard helps you with the rollback process. You can find the package information on the Welcome page.

2. Click **Next** to select the settings that you want to undo.

3. Click **Begin** to start the rollback process or **Cancel** to quit the process.

4. If you had rolled back the settings, select **Restart the computer** for the migration to take effect

5. Select **Delete undo\cleanup file** to delete the package.

6. Click **Finish**.
This chapter includes the following topics:

- Opening the Application Install Administrator
- About Application Install Administrator
- Defining the Application Installation
- Managing installation servers
- Providing a path for the Install File location
- Using the command-line options for installation and upgrading

Opening the Application Install Administrator

The Application Install Administrator is a new tool for creating the application installation .INI file. This tool reads all the .A2i files and finds out all the versions of the applications described in them. The tool reads the description for each version from the .A2i files.

The Application Install Administrator then shows a list of applications for which there is an entry in the .INI file based on these versions. The user can then select to install only one version, the same version, or the upgraded version of the selected application.
To open the Application Install Administrator

1. To open the **Application Install Administrator**, select Start > Programs > Altiris > PCTransplant > Tools > Application Administrator or run AppAdmin.exe.

2. Select **File > Open**.


About Application Install Administrator

The Application Install Administrator has two menus:

- **File**
- **Tools**

The Application Install Administrator supports two tools: Installation Server and Install File Location.

The following actions can be performed using the Application Install Administrator:

- Defining the Application Installation
- Authenticating Installation Servers
- Providing a Path for the Install File Location

Defining the Application Installation

You can define a list of properties required for the installation of the application that you have selected.

To define the installation

1. Select an application from the list of applications that appear based on the .A2i files.
   
   You can also expand the application and select a particular version of the application from the list.

   The application has a red icon if the installation information is not available in the .INI file.

2. Click **Define** to open the **Install Properties** page.

   The selected application pops up. You can define the properties required to install this application.
3 In the **Path to Install File** field, type the path where the install file exists. A warning message appears if the path is invalid.

4 If you selected the application, then select the version from the **Version** box. The **Version** box is disabled if you selected a particular version of the application in the **Application Install Administrator** page.

5 To create a new version of the application, type the new version in the **Version** box. You can create a new version only if the application is selected and not a particular version of the application in the **Application Install Administrator** page. You can add new information or modify the current .INI information.

6 Enter or browse to the path to select the installation file.

7 You can type the install and upgrade switches in their respective fields. Refer to the topic on Using the Command-line Options for Installation and Upgrading for more details.

8 Select **Wait for child processes to exit** before continuing with the migration to wait for any other executable files launched during installation. You can clear this option if the migration can continue without waiting for the child process.

9 Save the changes to the .INI file. You can also set the values for InstallFiles= and WaitForChildProcess= keys in the .INI file. If the application's installer launches any other executable files during the installation, you can specify if the utility must wait or continue with the installation of other applications. For more information, refer to *PC Transplant Reference Guide.* The installer's path is validated for existence. If you did not provide a UNC path, then a warning message appears with the potential problems that might occur if you use drive mapped paths. If the path is valid, then the new version is added to the particular application node. You can view the new version of the application in the **Application Install Administrator** page. The installer server information is also validated for existence.

---

**Managing installation servers**

The Installation Server helps in authenticating the servers that are used for installation purposes.
To manage an installation server


2. In the Installation Servers page, add a new installation server, click New.
   - To modify an existing installation server, click Edit.
     If you click New or Edit, the Installation Server Properties page appears.
   - To delete an existing installation server, click Delete.

3. In the Installation Server field, enter or browse to the path of the server.

4. In the User Name field, type the user name.

5. In the Password field, type the password and then confirm it.

6. Select the Validate Information check box to validate the server information that you have provided.

   PC Transplant tries to connect to the installation server with the connection credentials provided. A warning message appears if the server information is not valid. You can choose to add the server information or discard it.

   The Installation Server information is stored in the .INI file as:

   `[Installation Server]
   ServerName1 > User Name1 > Encrypted Password1
   ServerName2 > User Name2 > Encrypted
   Password2 ServerName3 > User Name3 > Encrypted Password3`

Providing a path for the Install File location

If the files mentioned in the command line options refer to the standard files present with this installation, then you must copy these files to some other location.

In the Install File Path field, browse or enter the path to copy all the installation files.

For information on Command line options in the Definition File, refer to the PC Transplant Reference Guide.
Using the command-line options for installation and upgrading

You can use command-line options in the **Install Properties** page to install or upgrade the application.

The command-line option that you type in the **Install Switches** field is used to install the application.

The command-line option that you type in the **Upgrade Switches** field is used to upgrade the application. You can also use this to uninstall the previous version and then install a new version of the application.
Using the command-line options for installation and upgrading
This chapter includes the following topics:

- Using the Template Builder
- About the Personality Build Template summary
- Using and Editing a Personality Build Template
- About the template settings options

Using the Template Builder

The Template Builder lets you build and edit templates outside the PC Transplant Wizard.

See “Personality build template options” on page 38.

The tool has an interface similar to the PC Transplant Wizard. As the tool is generic, you cannot select a specific user’s settings to migrate. The tool provides a list of all Desktop and Network settings and does not include any system specific options such as listing a specific printer.

The tool displays a list of all applications that are supported by PC Transplant. The list is built using the current applications defined in the .A2i files. No application versions are presented therefore keeping the template generic. The tool also includes all the applications for the .A2i files created by the user.

The Template Builder displays a list of applications that it finds defined as the .A2i files in a particular language’s folder.

For example: EN folder. Files, folders, and file types are also flexible.

You can add a file or a folder that may or may not exist on the source computer. The same flexibility is included with Filters.
About the Personality Build Template summary

After the Personality Build Template is created, a summary screen appears. The summary provides a list of the settings collected in the template file. Click Next to view or edit this file in a text editor.

Using and Editing a Personality Build Template

When a Personality Build Template is created, you can use it with the PC Transplant Wizard to transplant a computer’s settings and files.

You can view or edit the contents of a personality package by opening the file in a text editor. You can also easily edit a template through the Template Builder Wizard.

About the template settings options

You can configure the following settings for migration in the Personality Build Template:

- User Capture Options
- Computer Settings Options
- Application Install Options
- Files, Folders, and File Types Options
- Capture Options
- Deploy Options

Adding user capture options to the template

You can use the User Capture Options page to add the local and domain users to the template. You can redirect the users to another domain on the destination computer. You can also filter the users to be migrated based on user groups, domains, or the date the user account was created or accessed. You can also include disconnected users for migration.

Note: PC Transplant supports template files up to 4 GB maximum. However, the operating system and memory available on a computer may not support a file so large.
To add local and domain users to the template

1. To migrate local users, select **Capture Local Users**.
2. To redirect local users to another domain on the destination computer, enter the new domain in **Redirect to domain**.
3. To migrate domain users, select **Capture domain users**.
4. In the **Source** field, type the user whose settings you want to migrate.
5. In the **Destination** field, type the destination user.
   Ensure that you enter the domain name that the user belongs to.
   For example: Domain Name\User1.
6. Click **Add** to add the user to the template.
7. To include disconnected users in the template, select the **Include Disconnected Users** check box.
8. Filter the users for any of the following:
   - Users from one or more user groups
   - Users from one or more domains
   - Users based on the date the accounts were created or last accessed
9. After the filter options are selected, click **OK**.

To select users from one or more user groups

1. Click **Advanced Filters**.
2. In the **Filter User** dialog box, select the **Group filter** check box.
3. Select either of the following:
   - The user is a member of
   - The user is not a member of from the drop-down list.
4. In the **Group name** field, type the name of the user group
5. To add the group to the filter, click **Add**.
   To add more groups, repeat the steps 4 and 5.
6. To remove a group from the filter, select the group from the **Group area** and click **Remove**.

To select users from one or more domains

1. Click **Advanced Filters**.
2. In the **Filter User** dialog box, select the **Domain filter** check box.
3 Select either of the following:
   - The user is a member of
   - The user is not a member of from the drop-down list.

4 In the **Domain name** field, type the domain name.

5 To add the domain to the filter, click **Add**.
   To add more domains, repeat steps 4 and 5.

6 To remove a domain from the filter, select the domain from the **Domain** area and click **Remove**.

**To select users based on the date the accounts were created or last accessed**

1 Click **Advanced Filters**.

2 In the **Filter User** dialog box, select the **Date filter** check box.

3 Select any of the options from the drop-down list.

4 Select values for a period of time (in the last specified days or months) or specify a date using the calendar icon.

**Adding user map file to the template**

You can map the settings of one user account on the source computer to any account name on the destination computer in a user map file, and add this file to the template. When this template is used to create a package, the package will reference the specified user map file for how the users must be migrated to the destination computer. You can use the `-usermap` command-line option to perform the same action.

For information on command line options and user map file, refer to the *PC Transplant Reference Guide*.

**To add the user map file to the template**

1 Select the **Migrate users with a Usermap file** check box.

2 Type a filename in the **Location** box or click **Browse** and select the user map file.

**Viewing the computer settings options**

Use the Desktop Settings, Network Settings, and Application Settings tabs to select the computer’s settings that you want to migrate. The settings listed in the **Desktop** and **Network** tabs come from the information in the Dsktp*.ini and Ntwrk*.ini files. All of these files can be edited using a text editor.
For information on Desktop and Network Settings File Format, refer to the *PC Transplant Reference Guide*.

The default settings are configured in the build template file that you chose earlier. For information, see Personality Build Template Options.

You can view the details and the warnings of the settings that you selected:

- If you chose **Create a new Package** or **Edit an existing package** in the wizard, then the warnings for the application settings are displayed with respect to the source version to all the possible versions.

- If you chose **Real Time Migration**, then the warnings for the application settings are displayed with respect to the source version and the destination version.

- For the Template Builder, the warnings for the application settings are displayed for all supported versions to all possible versions.

**To view the details and warnings of the settings**

1. Click the appropriate tab.
2. Select the item whose properties you want to view.
3. Click **Properties**.
   
   The **Properties** page opens with the details and the warnings of the item that you selected.

**About the desktop settings**

The settings listed in the Desktop tab come from the information in the Dsktp*.ini file. This file can be edited using a text editor.

PC Transplant migrates properties under the following categories:

- Control panel
  - Accessibility
  - Keyboard Settings
  - Mouse Settings
  - Power Settings
  - Printer Settings
  - Regional Settings
  - Sound
  - Display Properties
You can now distinguish between local and network printers. Under the Desktop > Control Panel > Printer Settings, you can view and select the group of printers that you want to migrate. By selecting one or both printer options and saving it in a template file, an administrator can control the migration of the group of printers. You can also use the command line option -desktop with the personality package.

For information on command line options, refer to the *PC Transplant Reference Guide.*

**About network settings**

The settings listed in the **Network** tab come from the information in the Ntwrk*.ini file. This file can be edited using a text editor.

PC Transplant can migrate the following properties:

- Computer and Domain Names
- Window drive mappings
- Folder/Drive share assignments
- Dial-up/RAS connections
- Netware Windows Client (Client 32) Settings
- TCP/IP Settings

**About multiple NIC support**

When using multiple network cards in one computer, the user has the option of selecting the network card whose TCP/IP settings are to be captured. This
information is provided in the UI under TCP/IP for Network settings. On a
destination computer, you can also remap one NIC to another.

**Note:** With the Template Builder, you cannot select multiple NICs. If you choose
to migrate TCP/IP, then all the NICs are migrated.

## About computer and domain names

You can migrate the computer and domain names through a personality package.

**Note:** To avoid conflicts, this option is disabled during a real-time migration.

Before installing a personality package with a computer name or domain name
on a destination computer, the source computer must be disconnected from the
network. If the source computer is still connected to the domain, PC Transplant
will not establish a trust relationship with the domain for the destination computer.
Two computers using the same computer and domain names are not allowed by
Microsoft. If PC Transplant cannot establish this trust, the destination computer
is added to the `tmpwork` Workgroup. To continue, you have to manually connect
the destination computer to the domain.

A computer name migration requires that you be an administrator on both the
source and destination computers. In the event that you are migrating a computer
that is already added to a domain, you must also provide the user name and
password of an account that has the rights to change and create a computer
account in that domain. When a package with just the computer name is run on
a destination computer, a dialog box asks you for this information. The dialog box
appears only if the computer is currently a member of a domain. This is necessary
because of the trust relationship that exists between the domain and that computer.
PC Transplant associates the computer that is being migrated with the computer
account on the domain. If the account is not correctly associated with the computer
account on the domain, you cannot log on to any domain user accounts on that
computer.

A domain name migration requires you to be an administrator on both the source
and destination computers. Because of the nature of domain name migration, PC
Transplant requires that you provide the user name and password of an account
that has the rights to change and create a computer account in that domain. You
are prompted for this at the end of the PC Transplant Wizard when you click the
**OK** button or the **Schedule** button. You may also pass in a -dau and -dap switch
to specify the domain name from the command line. In quiet mode, the -dau and
-dap switches are required for a domain migration to take place. For information
about switches, see the Altiris PC Transplant Reference Guide. User authentication
for a domain is not stored in the template. The user name provided may need to be preceded by the domain name depending on the authentication model of your domain server. You can also pass an encrypted password in the command line. For information, see Password Encryption Utility.

About application settings

The settings listed in the Application tab come from the .A2i files you have and which applications are registered in the Windows registry as installed applications.

The list of applications in the Applications tab depends on what .A2i files you have and which applications are registered in the Windows registry as installed applications. If the application is not registered in the registry, the application is still displayed if you had specified the complete path of the .EXE or the complete or partial path with Type=Scan in the .A2i file.

The .A2i files are created for non-standard applications, that is, the applications that do not store their installation information with the registry.

For the PC Transplant Wizard, the applications that do not contain information in the registry are considered as if they are not installed. By default, these applications are not selected in the list. But if the Type=Scan tag is present in the .A2i for these applications, then these applications will be displayed in the list with a magnifying glass icon and a warning message. You can select such an application and when you click Finish to create a personality package, the target computer is scanned. The path for the scanning is retrieved from its .A2i. If only the application is found in the specified location, the application settings are picked up for migration. If the applications are not found during the search, then those applications are removed from the list.

During real-time migration, the actual scanning of the applications takes place when you click the Finish button to start the migration. If the application is found on both the source computer and the destination computer, then the application settings are migrated.

For information, refer to the PC Transplant Reference Guide.

Updating the .A2i files

The Application to Information (.A2i) files which support the additional applications are available as a free download from Altiris’ Web site at ftp://support.altiris.com/pct/ver6.x/EN.

If you are using applications for which no .A2i files exist, PC Transplant ships a utility with A2i Builder that lets you build your own custom .A2i files.
To update the .A2i files

- To update the .A2I files, do either of the following:
  - From within the PC Transplant Editor, select Help > Application Updates. The computer connects to the Altiris Web site, searches for new or updated .A2i files, and presents them for automatic download.
  - Run the PC Transplant Wizard or the Template Builder and click the system menu > Update Application Support. The original files are placed in the Backup folder before updating the .A2i files.

About application install options

You can use the Transplant Install Application page to select the application to be installed on the destination computer. You can choose to install the same or higher version of the applications.

The Transplant Install Application page allows you to define an application installation file. You can select the applications and the corresponding version from the Applications and Version Options list. The Version Options are the Highest Version or Same Version for the Template Builder and the PC Transplant Wizard to create a personality package.

During the real-time migration, the actual versions for the particular application are displayed. For information, see Providing Information for Application Installation. During real-time migration, some applications would require you to restart the computer after installation. In such cases, the Application Installer tool gets launched to install other applications that you selected from the list, but only if you log on using the same user name.

When doing a real-time migration, you are shown information about the applications that are installed on both the source and destination computers. Applications that are installed on the source computer but not on the destination computer are designated so that you do not transplant settings for an application that does not exist on the destination computer. You are also shown information about the applications that are installed on each computer but are different versions.

For example, if Microsoft ActiveSync is installed on the source computer, but not on the destination computer, ActiveSync will be displayed in the application list, but it will be denoted as not being installed, and you will not be able to select settings for that application.

---

Note: This feature is not available for a real-time migration on the same computer.
For the Template Builder, this page appears if any applications are selected for migration. All the applications selected for migration are disabled initially. If the application installer definition file that you provided contains the install information and the install server information for the applications selected for migration, then the application list is enabled. The applications that are listed can be installed using the information defined in the Application Install Administrator.

Providing information for application installation

You can select the application to be installed and specify an installation file for the information on the installation. You can also create or edit the installation file using the Application Install Administrator tool.

To specify an .INI file

1. Click **Browse**.
2. Browse or enter the install definition file.

To select applications to be installed on the destination computer

1. From the Applications list, select the application.
2. From the **Version Options** list, click **Highest Version** or **Same Version** against the selected application.
3. Click **Next**.

You can also edit any of the install options defined in the Application Install Administrator.

To create an .INI file

◆ Click **Define**.

The Application Install Administrator tool launches.

About the installation status

The installation status of an application can be viewed by clicking the **Current State** button in the PCTAppInstaller dialog box. Clicking this button displays the main application install and any additional installs it may have executed. To end an installation process, select it and click the **End Process** button. To view the latest state of the install processes being executed, click the Refresh button. If you end a parent install process, its child processes disappear from the PCTAppInstaller dialog box, although the child processes continue running on the destination computer.
About canceling the application's installation

You can cancel the application's setup while installing the applications. You can select to exit PC Transplant Application Installer only or to exit both the Application Installer and the Application Setup. After cancellation, if you are performing real-time migration the destination agent is launched to resume the migration.

About files, folders, and file types options

You can use the Transplant Source PC's Files and Folders page to include or exclude files to be migrated. You can select to include or exclude files based on criteria, such as filenames, folders, file types, drives, file size, and file date. The files, folders, and file types that are selected by default are ones that are configured in the build template file that you selected earlier (step 3 on page 13).

See “Personality build template options” on page 38.

From the Transplant Source PC's Files and Folders page, you can perform the following:

- Add Files, Folders, or File types
- Delete Files, Folders, or File types
- Exclude Files, Folders, or Drives
- Prioritize Files, Folders, and File types to Migrate
- Set Advanced Options

Adding files, folders, or file types

You can add specific files, folders, or file types to migrate.

To add specific files

1. Click the Files tab.
2. Click Add New.
   In the dialog box, you can add a file in two ways: from a path or by specifying a filename and adding all files with that name from multiple paths.
3. In the File name field, enter a filename or browse to a file.
4. To add all files of the same filename, enter a filename and select the All files with these names check box in the Options pane.
5. Click Open.
To add specific folders

1 Click the Folders tab.

2 Click Add New.
   In the dialog box select the folders that you want.

3 To add a folder in addition to the selected folder, type the complete folder path of the folder that you want to add.
   The folder gets added to the list of folders that you have already selected.

4 To include all the subfolders and the files of the selected folder, select the Include Subfolders check box.
   To include only the files of the selected folder, do not select Include Subfolders.
   To exclude the files of the selected folder from migration, click Advanced to use the advanced options.

5 To exclude the files of the selected folder from migration, click Advanced to use the advanced options.

To add specific file types

1 Click the File Types tab.

2 Click Add New.
   A dialog box appears, letting you select a file type or create a custom type.

3 Select a file type from the list or click Custom to create a custom file type.
   If you click Custom, then do the following:
   ■ In the dialog box that appears, type the extension in the File Type field
   ■ Type the description of the file type in the Description field.
   ■ Click OK.

4 Click OK.
   The file type is added to the list of the existing file types. The new file type is retained throughout.
   You can use environment variables and wildcard characters while adding file, folder, or file type.
   For information, see Environment Variable Support and Wildcard Support.

Deleting files, folders, or file types

You can delete specific files, folders, or file types that you do not want to migrate.
To delete files, folders, or file types
1  Click the appropriate tab.
2  Select the files, folders, or file types that you want to remove from the list.
3  Click Remove or press DELETE.

After you have a list of files, folders, and file types, you can clear the check box for the ones that you do not want to migrate.

Excluding files, folders, or drives
You can exclude file types, files, folders, or drives through a Global Filter.

To exclude files, folders, or file types
➢  Click Filter from the Transplant Source PC's Files and Folders page.
   For information on how the Global Filter works, see Filter Files, Folders, and Drives.

Prioritizing files, folders, and file types to migrate
The Global Filter, along with each file, folder, or file type that you specify, constitutes a rule for migration. You can prioritize your rules to ensure that you transplant only the items you want to migrate.

To prioritize files, folders, and file types to migrate
➢  To establish a priority of the included rules and Global Filter, click Prioritize.
   For information, see Prioritize Rules.

Setting advanced options
The advanced options provide additional flexibility.

Based on the type of file, folder, or file type you are working with, you can do one or more of the following:
➢  Select specific files or file types from a folder to be included or excluded.
➢  Include files based on file size and date.
➢  Redirect files and folders to a new destination
➢  Save all the transplanted data in a single folder or retain the same directory structure as on the source computer.
➢  Exclude drives, folders, subfolders, file types, or files.
To configure advanced settings
1. Add a file, folder, or file type.
2. Select one or more items from the list.
3. Click Advanced.

To turn off/on advanced settings for a particular item
1. Select one or more items.
2. Right-click on the selected item.
3. Select Off to turn off the advanced settings or Select On to turn on the item back.

You can specify the advanced options in the page that appears.
For information, see Advanced Files Settings, Advanced Folders Settings, and Advanced File Types Settings.

About the advanced file settings
The advanced file options let you specify additional criteria and settings for individual files. You can use the multiple selections to edit the advanced options of a set of files. If you select multiple files, then the Multiple Files Advanced Options page appears. If you select a single file, then the File Advanced Options page appears.

The File Advanced Options page has the following three tabs:
- General
- File Filter
- Search

If you select multiple files and set their advanced options, the options common to all the selected files are displayed in the File Filter tab. When multiple files are selected, the Search tab is not available.

About the advanced folders settings
The advanced folders options let you specify additional criteria and settings for individual or multiple folders. You can use the multiple selections to edit the advanced options of a set of folders. If you select multiple folders, then the Multiple Folders Advanced Options page appears. If you select a single folder, then the Folder Advanced Options page appears.

The Folder Advanced Options page has the following three tabs:
- General
■ Exclude

■ Search

If you select multiple folders and set their advanced options, then the options common to all the selected folders are displayed in the Exclude tab. When multiple folders are selected, the Search tab is not available.

About advanced file types settings

The advanced file type options let you specify additional criteria and settings for individual or multiple file types. You can use the multiple selections to edit the advanced options of a set of file types. If you select multiple file types, then the Multiple File Types Advanced Options page appears. If you select a single file type, then the File Type Advanced Options page appears.

The File type Advanced Options page has the following three tabs:

■ General

■ Exclude

■ Search

If you select multiple file types and set their advanced options, the options common to all the selected file types are displayed in the Exclude tab. When multiple file types are selected, the Search tab is not available.

Adding filter files, folders, and drives

You can select to exclude files, folders, and drives through the Global Filter feature. The File Filter, Folder Filter, and Drive Filter tabs each display a list of excluded default objects. For file and folder filters, you can select, clear, add, or delete items in the list. For drive filters, you can select or clear the items but cannot add a new item.

You can set the filter options from the Options tab:

■ To include setting files despite any filters provided, select Do not apply filters to settings files from the Setting Filter area.

■ To exclude profile folders of users who are not selected for migration, select Do not search profile folders of non-selected users from the User Profile Folders area.

Note: For Template Builder, you can add or delete a drive filter item.
To add a file or folder to the filter

1. From the Transplant Source PC's Files and Folders page, click Filter.

2. In the File, Folder and Drive Filters page, add the specific files or folders to the Global Filter and click Add New.

   Follow the directions in the dialog box.

   When you have a list of files, folders, and drives, you can select or clear the check box for the ones you want to migrate. Each selected item becomes part of the Global Filter.

   All items in the Global Filter will be excluded unless another rule is given a higher priority.

   For information about rules and priorities, see Prioritize Rules.

About prioritize rules

The prioritize feature provides a method for managing the collection of individual files. When selecting which files to include or exclude, you can use filters and rules to manage which files to migrate. You can filter out specific files, folders, and drives through a Global Filter. You can also select to include specific files, folders, and file types.

Each file, folder, or file type that you include (which is selected in the lists under the Files, Folders, and File Types tabs) is considered a unique rule for migrating files.

You can use the priority feature to determine which rule must take priority to resolve the conflict among the included rules and the Global Filter.

---

Note: If the Global Filter is changed from the highest priority, then PC Transplant scans for the files with higher priority than the Global Filter in all the drives that are excluded through the Global Filter. This would increase the package creation time.

---

An example of conflict between the included rules and Global Filter is as follows:

- Suppose you exclude a folder named C:\Data in the Global Filter

- Include all .XLS files under the File Types tab.

  Suppose the Global Filter has higher priority than the *.xls file type. Then there is a conflict of rules if an .XLS file exists in the C:\Data folder. The include .XLS rule conflicts with a setting in the Global Filter.

  By using the prioritize feature, you can determine which rule gets a higher priority. If you give "*.xls files" rule a higher priority than the Global Filter,
then the .XLS file in the Data folder will be migrated, but all other files in the Data folder will not. If the Global Filter is given a higher priority than the ".xls files" rule, then the .XLS file in the Data folder will not be migrated, but all other .XLS files in other folders will be migrated.

An example of conflict among the different included rules are as follows:

■ Include a file C:\a\a.txt
■ Add a folder C:\a in the Folders
■ Exclude C:\a\a.txt

If you give included file C:\a\a.txt higher priority than C:\a, then the file C:\a\a.txt will be picked up. If C:\a has higher priority than C:\a\a.txt, then C:\a\a.txt will be excluded from migration. If C:\a\a.txt is redirected, then C:\a\a.txt will be picked up irrespective of the priority to other files or folders unless the Global Filter excludes it.

To help you remember how each rule is configured, you can select a rule and click Properties. For files, folders, and file types, you can see if advanced settings were configured, and if so, what those settings are. For the Global Filter, you will be shown what files and folders have been excluded.

You can set the priority of a rule in the following ways:

■ Select a rule and click Set Priority. You can then select to move the rule up or down in either an absolute or relative position.
■ Select a rule and then click the up or down arrows.
■ Select a rule and drag it up or down.

Using the Capture options

From the Capture Options page, you can configure the following options:

■ Spanning Media
■ Compression Options
■ Creating a Self-extracting Package
■ Advanced Options

Configuring the Spanning Media option

The Spanning Media option lets you place a personality package on multiple drives or on multiple storage devices if the personality package size exceeds 2 GB or the specified span package size. You will be prompted to specify a new folder. When you select the new folder, the program continues.

Spanning works in the following manner
Each spanned file follows the syntax package filename.###, where ### is a hex number starting from 001 (example: a package called install.exe that spanned over four files would also include an install.001, install.002, and install.003). When the package is executed, it will run until it needs the next file for spanning. You will then be prompted for the next file if it cannot be found.

To configure span options

1. Select the **Span package** check box.
2. Select a package size from the **Size** drop-down list.
   The range of values for custom size is from 10 to 2000 MB.
3. Define a name and path where you would like to save the personality package executable file.
   You can save your selections as a template for future use.

### Disabling the Compression Options

You can disable compression for files that are migrated. You can disable compression for all files or you can specify individual files or file types. Removing compression for files that are already compressed can decrease the time required to migrate a file.

For example, by default, PC Transplant compresses all Microsoft Outlook's .PST files.

**To disable compression for all files**

1. Select **Disable compression** for all files.
2. In the **Files** pane, click **Add New** to add files for which the compression is to be disabled.
   You can also select a file from the list and click **Remove** to enable compression.
3. In the **File Types** pane, click **Add New** to add file types.
   You can also select a file type from the list and click **Remove** to enable compression.
4. Click **OK**.

### About creating a self-extracting package

By default, the Create a self-extracting package (not recommended for Windows Vista) check box is selected for non-Windows Vista computers. If you select this check box for a Windows Vista computer, a .EXE file is created as the self-extracting package. If you do not select this check box for a Windows Vista computer, .EXE
and .PKG files are created as the Personality Package. The .PKG file is not associated with PC Transplant. You have to use the .EXE file to run the .PKG file.

About advanced options
There are the following four tabs in the Options page:
- Paths
- Undo
- Security
- Other

The following options are used when the personality package is executed on a computer or during real-time migration:
- Paths Options
- Undo Options
- Security Options
- Other Options

About the Deploy options
From the Deploy Options page, you can configure the following options:
- Display Options
- Advanced Options

The following options determine how a migration is performed:

<table>
<thead>
<tr>
<th>Option</th>
<th>What it does</th>
</tr>
</thead>
<tbody>
<tr>
<td>Package Display</td>
<td>Configures the display options when the personality package is run.</td>
</tr>
<tr>
<td></td>
<td>See Display Options.</td>
</tr>
<tr>
<td>Run Personality Package in quiet mode</td>
<td>Executes the personality package on the destination computer without any user intervention.</td>
</tr>
<tr>
<td>Run minimized</td>
<td>Executes the personality package as a background process.</td>
</tr>
</tbody>
</table>
### Table 7-1  migration options (continued)

<table>
<thead>
<tr>
<th>Option</th>
<th>What it does</th>
</tr>
</thead>
<tbody>
<tr>
<td>Always Replace</td>
<td>Always replaces the duplicate files on the target computer. This is the default option.</td>
</tr>
<tr>
<td>Older Files with Newer</td>
<td>Replaces older duplicate files with newer files when the personality package self-extracts.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong>: If you choose real-time migration to migrate the settings to the same computer, then the migration always replaces the older</td>
</tr>
<tr>
<td></td>
<td>duplicate files with the newer files. All the options are disabled in this case.</td>
</tr>
<tr>
<td>Never Replace</td>
<td>Never replaces the duplicate files on the target computer.</td>
</tr>
<tr>
<td>Prompt before replacing a file</td>
<td>Prompts the user before replacing any duplicate files.</td>
</tr>
<tr>
<td>Restart destination computer</td>
<td>Restarts the computer after the personality package finishes running or after the real-time migration is completed. This option is</td>
</tr>
<tr>
<td>after the migration</td>
<td>recommended for most personality packages to ensure that changes are made to the hard disk.</td>
</tr>
</tbody>
</table>

**Note**: For the File Replace transplant options, the migrated .INI files do not replace an existing .INI file on the destination computer. The settings of the .INI file gathered on the source computer are merged into the .INI file on the destination computer.
PC Transplant Package Editor

This chapter includes the following topics:

- About using the PC Transplant Package Editor
- Opening a Personality Package
- Viewing and Changing Advanced Settings
- Viewing and Changing Registry Settings
- Viewing and Changing Files and File Structures
- PC Transplant Package Editor Menu Features
- Extracting a File from a Package

About using the PC Transplant Package Editor

The PC Transplant Package Editor lets you easily view and change an existing personality package. You can also launch PC Transplant tools and update .A2i files. The PC Transplant Package Editor displays the title, description, created date, created version, total number of files and folders, and the total size of files and folders of the personality package.

Opening a Personality Package

To open the package, few packages require a password to be entered before executing the package. If you enter an incorrect password in the first attempt, package execution is not terminated. You can continue re-entering the password until you enter the correct password or cancel the package execution.
To open the Personality package

1. To open the PC Transplant Package Editor, select **Start > Programs > Altiris > PCTransplant > Tools > PC Transplant Editor** or run PCTEDIT.EXE.

2. Select **File > Open**.

3. Browse to select an existing personality package.

   You can also click **File**, and select a personality package from the list.

### Viewing and Changing Advanced Settings

**To view and change the advanced setting**

1. Open a personality package.

2. Click an item in the **Advanced Settings** area to display settings in the right-hand area.

3. Right-click a setting and click **Delete, Copy, or Properties**.

### Viewing and Changing Registry Settings

**To view and change registry settings**

1. Open a personality package

2. Browse through the registry settings.

3. Right-click an item to Add Item, Delete, Copy, Paste, or view Properties.

4. When settings appear in the right-hand area, right-click the items and click Add Item, Delete, Copy, Paste, or Properties.

### Viewing and Changing Files and File Structures

**To view and change files and file structures**

1. Open a personality package.

2. Browse through the registry settings.

3. Right-click an item to Add Item, Delete, Copy, Paste, or view Properties of file structures.

4. When individual files appear in the right-hand area, right-click and select Add Item, Delete, Copy, Paste, or Properties.
## PC Transplant Package Editor Menu Features

The PC Transplant Package Editor provides the following features to view and change an existing personality package.

### Table 8-1 Editor Menu Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
<th>Button Access</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open</td>
<td>Opens a window from which you can browse and open a personality package.</td>
<td>Ctrl+O Click File &gt; Open.</td>
</tr>
<tr>
<td>Close</td>
<td>Closes the personality package without saving it.</td>
<td>Click File &gt; Close</td>
</tr>
<tr>
<td>Save</td>
<td>Saves the personality package.</td>
<td>Ctrl+S Click File &gt; Save.</td>
</tr>
<tr>
<td>Save As</td>
<td>Saves the personality package with a different name and path if required.</td>
<td>Click File &gt; Save As</td>
</tr>
<tr>
<td>Undelete</td>
<td>Retrieves the last deleted item</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Find</td>
<td>Searches for items within the selected structure (registry or file folder).</td>
<td>Ctrl+F Click Edit &gt; Find.</td>
</tr>
<tr>
<td>Add Item</td>
<td>Adds an item to the selected structure</td>
<td>Right-click an item and select Add Item</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected item</td>
<td>Right-click an item and select Delete</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies the selected item</td>
<td>Right-click an item and select Copy</td>
</tr>
<tr>
<td>Paste</td>
<td>Pastes the copied item to the selected structure</td>
<td>Right-click an item and select Paste</td>
</tr>
</tbody>
</table>
### Table 8-1  Editor Menu Features (continued)

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
<th>Button Access</th>
</tr>
</thead>
<tbody>
<tr>
<td>Properties</td>
<td>Opens the Properties window for the selected item</td>
<td>Right-click an item and select Properties</td>
</tr>
<tr>
<td>Options</td>
<td>Opens the Options page where you can change the Run and Display options.</td>
<td>Click Edit &gt; Options</td>
</tr>
<tr>
<td></td>
<td>See “Deploy options” on page 66.</td>
<td></td>
</tr>
<tr>
<td>Migrate User Settings</td>
<td>Opens PC Transplant Wizard.</td>
<td>Click Tools &gt; Migration Wizard</td>
</tr>
<tr>
<td></td>
<td>See “About transplanting PC’s Settings and Data” on page 27. See</td>
<td></td>
</tr>
<tr>
<td>Create Report</td>
<td>Opens Package Content utility. See Viewing, Printing, or Changing Personality Package Contents</td>
<td>Click Tools &gt; Package Report</td>
</tr>
<tr>
<td>A2i Builder</td>
<td>Opens A2i Builder utility</td>
<td>Click Tools &gt; Custom A2i Builder</td>
</tr>
<tr>
<td>Build PCT Templates</td>
<td>Opens Template Builder utility.</td>
<td>Click Tools &gt; Template Builder</td>
</tr>
<tr>
<td></td>
<td>See “Using the Template Builder” on page 99.</td>
<td></td>
</tr>
<tr>
<td>Application Updates</td>
<td>Updates existing .A2i files or adds new .A2i files to your list of supported applications</td>
<td>Click Help &gt; Application Updates</td>
</tr>
<tr>
<td>Online Help</td>
<td>Opens online help.</td>
<td>Click Help &gt; Contents and Index.</td>
</tr>
</tbody>
</table>
Extracting a File from a Package

The PC Transplant Package Editor can extract a file from a package and move it to a specified destination without having to migrate any settings.

To extract a file from a package

1. Open a personality package.
2. In the Folders window, browse for the folder that contains the file you want to extract.
3. In the main Editor window, select the file.
   - You may select more than one file to save to a single folder.
4. Right-click > Save As.
5. Choose a destination for the file and click Save.
Extracting a File from a Package
This chapter includes the following topics:

- A2i Builder
- Creating, Editing, or adding versions to A2i Files

**A2i Builder**

The A2i Builder Wizard helps you create customized .A2i files for a particular application by monitoring the changes made by user to that application. When applications contain settings that go beyond the capabilities of the A2i Builder, you will be required to manually modify these files using the A2i editor.

If we attempt to edit an .A2i file of an application that is not installed on the computer using the A2i builder, then all the settings present in the .A2i file may not be displayed. This occurs because some registry entries are not present on the computer, so they are not resolved, and are not displayed. For seeing and editing all the entries present in an .A2i file, use the .A2i editor. The A2i editor displays all entries without resolving any registry or file setting.

See “Using the A2i Editor” on page 139.

**Note:** Before using the A2i Builder, read "Application to Information (.A2i) format" in the Altiris PC Transplant Reference Guide which describes the contents of an .A2i file and how to build or edit an .A2i file manually using a text editor. This knowledge will help you understand the functionality and limitations that you may find when using the A2i builder. Any Windows user can use the A2i Builder, but to utilize some of the more advanced capabilities found in an .A2i file, you need advanced knowledge of Windows registries, folders, and files.
Creating, Editing, or adding versions to .A2i Files

Due to some operating systems limitations, the A2i Builder with its supporting files, regsys.sys and regvxd.vxd, should be stored and run from the computer's local hard disk.

To create, edit, or add versions to .A2i files

1  If you have installed PC Transplant on the local computer, you can run the A2i Builder Wizard in the following ways:
   ■ Select Start > Program Files > Altiris > PCTransplant > Tools > A2i Builder.
   ■ From the PC Transplant Package Editor, select Tools > Custom A2i Builder.
   ■ Run A2ibuild.exe.

2  Select an option to create, edit, or add another version to an .A2i file:
   To create a new file
   ■ Click Create an A2i File.
   ■ Click Next.
   ■ Continue with step 3.
   To add another version to a file
   ■ Click **Add a new version** to existing A2i file.
   ■ Click **Add New Version**.
   ■ Click **Next**.
   ■ Select the .A2i file to which you want to add a version or click Browse to browse to the application if the application is not present in the application list.
   ■ Click **Open**.
   ■ Continue with step 5.

3  Select an application from the list of installed applications and click Next.

4  Click Launch to launch the application or you can directly enter the application's settings in the Registry, Files and Folders, and File Types tabs.

5  Select the registry items that you want to include in the .A2i file and click **Next**.

6  Add any additional files and folders that you want to include in the .A2i file and click **Next**.

7  Select the file types you want to add to the .A2i file and click **Next**.
8  Browse to the location where the .A2i file will be added and enter a name for the .A2i file.

   This page appears only if you are manually creating or editing an existing .A2i file.

   See Select the .A2i File Name.

9  After the .A2i file is created, you can view, edit, or use the .A2i file. Click Next.

   See View, Edit, or Use the .A2i File.

10  View the creation summary and click Finish to close the wizard.

    After you have built the file, you can view and edit the contents of the .A2i file using a text editor.
A2i File Settings

This chapter includes the following topics:

- Select the Required Application
- Select the .A2i File Name
- Capturing the application’s settings
- Adding Registry Items
- Adding Files and Folders
- Adding File Types
- Viewing, Editing, or Using the A2i File
- Creating A2i Summary
- Legacy Applications
- Submitting .A2i Files to Altiris Test Site

Select the Required Application

A2i Builder scans Windows for the current list of installed applications and displays a list for your selection. Some application executables provided by the operating system do not use the "Product Description" field to describe the application, but use a generic "Microsoft Windows" description. In this case you may want to refer to the executable name following the description in parenthesis. If you do not find your application listed, you can browse for the application.

To select an application

1. Select an application from the list of installed applications or
2. Click Browse to select an application which is not listed
Select the .A2i File Name

While creating an .A2i file manually, you can change the default path where the .A2i file is located.

To select the .A2i filename, there are 2 options specified:

1. Option 1: Specify the name and path in the A2i file name box.
2. Option 2: Click Browse and navigate to the required location and type the name of the .A2i file.

Note: If you save the .A2i file in any path other than the default path, then you cannot use the Try Now feature after you finish creating the .A2i file. See View, Edit, or Use the .A2i File.

Capturing the application's settings

A2i Builder launches the application to capture the application's settings. While the application is running, the A2i Builder monitors all changes the application makes to the registry and the file system. The A2i Builder displays the registry keys and files that are modified by the application in the Capture Settings dialog box. You can edit and filter the modified registry keys and files that are being captured in the .A2i file. Some applications do not write their settings until they are closed.

Note: If the launched application does not make changes in the registry, then A2i Builder will not be able to monitor the launched application's changes.

To modify the application's settings:

1. Click Launch. The Capture Settings dialog box appears.
2. Click in the Registry or File pane, and click Clear List to delete the registry or file settings captured.
3. Define the settings that are displayed in the Registry or File pane by selecting Show Accessed/Modified Entries Only or Show Modified Entries Only in the drop-down list.
Adding Registry Items

Read through the list of application-specific registry values the wizard presents, but avoid the temptation to select all the settings the wizard has presented. While the A2i Builder can monitor changes made to your application, it may be difficult to capture a true representation of an application's settings. By manually going through each registry value and selecting only those values you feel are relevant, you can avoid migrating a registry setting that is computer-specific or that may not even be an application setting. The trick to selecting a valid registry setting is to use its descriptive value name to match it with an option listed by your application. You can view the registry item's value by clicking View Data. You can delete registry items, files, folders, and file types by clicking Reset. You can also see Add Files and Folders and Add Files Types for more information.

To add registry items to the .A2i file

1. Click Add. The Browse Registry dialog box appears.
2. Browse to the registry keys to be added.
3. Click OK

Adding Registry Filter

You can determine what registry items are passed on to the user and give the user the ability of checking which registry items to include in the .A2i file. To add registry items to the filter

To add registry items to the filter

1. Click Filter. The Advanced Filter dialog box appears.
2. Click Add Registry. The Browse Registry dialog box appears.
3. Browse to the registry keys to be added.
4. Click OK twice

Modifying a Registry, File, Folder, or File Type property

Registry values, files, folders, and file types can include properties that describe special handling that should occur when an item is captured or migrated to a computer. You can view the properties by clicking the Advanced button. Examples of properties include reboot options, what destination operating system the item supports, deletion properties, and so on. The following table provides the properties supported by the A2i Builder and their descriptions.
<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No reboot / logout</td>
<td>Select this property if the destination computer will not require a restart or logout for this registry value or file to become active.</td>
</tr>
<tr>
<td>Requires reboot</td>
<td>Select this property if the destination computer will require a restart for this registry value or file to become active.</td>
</tr>
<tr>
<td>Requires logout</td>
<td>Select this property if the destination computer will require a logout for this registry value or file to become active.</td>
</tr>
<tr>
<td>Custom</td>
<td>Select the restart or logout option based on the destination operating system.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Migrate on all OS's</td>
<td>Migrates an item, no matter what Windows operating system is installed on the destination computer.</td>
</tr>
<tr>
<td>Migrate on same OS</td>
<td>Migrates an item only if the Windows operating system on the destination computer matches the operating system of the captured source computer.</td>
</tr>
<tr>
<td>Custom</td>
<td>Migrates an item based on the specific Windows operating system version of the destination computer.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete (this property applies to only registry items)</td>
<td>Delete all subkeys and values, delete only those registry values that contain paths, or move a specific registry key, prior to applying the new registry key or value. Some registry value or keys may need to be removed prior to migrating a specific registry value. This may be required to ensure a clean environment of the destination application.</td>
</tr>
<tr>
<td>Log error if not found</td>
<td>If the item cannot be found on the source PC, log an error to the summary log file.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Exclude this item</td>
<td>Exclude this item from the package. If the item is found in the package, it is removed</td>
</tr>
<tr>
<td>Exclude any values contain file paths (Registry specific)</td>
<td>If the registry value contains a file path, exclude it from the package. It may be necessary to do this if a registry value has a path that is specific to the source application or setting.</td>
</tr>
<tr>
<td>Do not replace item</td>
<td>If the item is already present at the destination PC, do not replace it.</td>
</tr>
<tr>
<td>Item requires administrative rights</td>
<td>If the item is already present at the destination PC, do not replace it.</td>
</tr>
<tr>
<td>Destination version match</td>
<td>Do not migrate this item if the destination application version does not match that of the source.</td>
</tr>
</tbody>
</table>

### Submitting .A2i Files to Altiris Test Site

After creating .A2i files for custom applications, a user can submit these customized .A2i files to the Altiris Web site for approval. The .A2i files can be submitted to the following URL: ftp://ftp.altiris.com/pct/ver6.x/waitingapproval.

### Adding Files and Folders

The files and folders that are captured for the application are displayed. From the displayed files, select the files to be added in the .A2i file. You can also add any additional files and folders that you want to include in the .A2i file. You can also select to exclude files, folders, and drives through the Global Filter feature. The **File Filter** **Folder Filter** and **Drive Filter** tabs each display a list of excluded default objects. For file and folder filters, you can select, clear, add, or delete items in the list. For drive filter, you can select or clear the items but cannot add a new item. While adding folders, select Include Subfolders to add the subfolders of the folder to the .A2i file.

When you select a specific file or folder, the wizard attempts to use an environment variable to help define its path (example: C:\WINNT\CDPlayer.exe will change to %MI_SYSTEM%\CDPlayer.exe). The wizard substitutes a path with an environment variable so that a path can be generic, regardless of the destination computer’s folder structure. If you do not select a file or folder from a path that is managed by the operating system, you will receive a warning. Any path that does not have
an environment variable will be transplanted to the destination computer as it has been defined. If you do not have the same path structure on the destination computer, your application file might not be recognized.

To add files and folders to the .A2i file

1. Click Add New, and select Add File or Add Folder.
2. Browse to the files or folders to be added. While adding folders, select Include Subfolders to add the subfolders of the folder to the .A2i file.

Adding files, folders, or drives to the filter

You can determine the files and folders that are passed on to the user and give the user the ability of checking which files and folders to include in the .A2i file.

To add files, folders, or drives to the filter

1. Click the Files and Folders tab.
2. From the A2i File Settings page, click Filter.
   - The File, Folder and Drive Filters page appears.
3. To add specific files or folders to the Global Filter, click Add New.
   - A dialog box appears. Follow the directions.

Adding File Types

The wizard attempts to find any file types your application may have registered with the operating system. An example of an application's file type would be .WPD for Corel WordPerfect or .DOC for Microsoft Word. To gather these types, the registry is searched for file types that use the same common name as your application. If your application has file types registered that do not follow this guideline, you may need to add these file types manually.

Viewing, Editing, or Using the A2i File

After the .A2i file is created, the following actions can be performed. Before using the A2i Builder, read "Application to Information (.A2i) Format" in the Altiris PC Transplant Reference Guide, which describes the contents of an .A2i file, and how to build or edit an .A2i file manually using a text editor. This knowledge will help you understand the functionality and limitations that you may find when using the A2i Builder. Any Windows user can use the A2i Builder. To utilize some of the more advanced capabilities found in an .A2i file, you need advanced knowledge of Windows registries, folders, and files.
Click **Try Now** to launch the PC Transplant Wizard in the quiet mode and create a personality package that contains the .A2i file’s settings. The created package is opened in PC Transplant Editor for further editing. If the .A2i file is not saved in the default folder, then A2iBuilder displays an error message stating that the .A2i file must be saved in the C:\Program Files\Altiris\PCT\EN folder.

- Click View to view the file in a text editor.
- Click Edit to edit the file in A2iEditor. Example: you can add the date, author.

### Creating A2i Summary

A2i creation summary shows the information given below about the .A2i file. You can also view this information by opening the .A2i file in a text editor. See View, Edit, or Use the .A2i File.

- A2i filename and the path where it is located
- Application for which the .A2i file was created
- Source language
- .A2i file creation date
- .A2i file creation time

### Legacy Applications

When PC Transplant supports any application that is more than two revisions behind the latest version, that application is archived and appears within an Legacy Applications folder. You can find this legacy folder under each of the language folders that are in the PC Transplant installation folder hierarchy.

You can use the migration templates for any of these unsupported applications by copying the a2i file from the legacy folder back into the primary directory.

The legacy folder contains the following applications:

- Adobe Illustrator
- Adobe Photoshop
- Altiris CarbonCopy
- AOL Instant Messenger
- American Online
- AT&T Global Network
- Corel Paradox
• Corel Presentations
• Corel Quattro Pro
• Corel WordPerfect
• FileMaker Pro
• Globalscape CuteFTP
• ICQ
• Jasc Paint Shop Pro
• Lotus 1-2-3
• Lotus Approach
• Lotus FastSite
• Lotus Freelance Graphics
• Lotus Organizer
• Lotus ScreenCam for NT
• Lotus SmartCenter
• Lotus Word Pro
• McAfee VirusScan
• Microsoft ActiveSync
• Microsoft C++
• Microsoft FrontPage
• Microsoft NetMeeting
• Microsoft Publisher
• Microsoft Visual Basic
• Microsoft Visual Foxpro
• Microsoft Visual InterDev
• Microsoft Visual SourceSafe
• Netscape
• Novell GroupWise
• NullSoft Winamp
• Palm Desktop Application
• Pumatech Intellisync for Palm Computing Platform
Submitting .A2i Files to Altiris Test Site

After creating .A2i files for custom applications, a user can submit these customized .A2i files to the Altiris Web site for approval. The .A2i files can be submitted to the following URL: ftp://ftp.altiris.com/pct/ver6.x/waitingapproval.
Submitting .A2i Files to Altiris Test Site
Using the .A2i Editor

This chapter includes the following topics:

- Using the A2i Editor
- Opening an .A2i file for Viewing and Editing
- Viewing the A2i Editor Menu Features

Using the A2i Editor

The Altiris A2i Editor lets you easily view and change an existing .A2i file. It provides an easy to use GUI interface and provides the drag and drop functionality to copy settings from one version to another. The A2i Editor lets you enter settings for applications whose settings cannot be captured when A2i Builder launches the application. You can also launch the PC Transplant Wizard from the A2i Editor to create a personality package that contains the edited .A2i file. The A2i Editor displays the versions, sections, and variables of the .A2i file.

Opening an .A2i file for Viewing and Editing

Use the following steps to open an .A2i file for viewing and editing.

To open an .A2i file

1. Select Start > Programs > Altiris > PCTransplant > Tools > A2i Editor or run A2iEditor.exe.
2. Select File > Open
3. Browse to an existing .A2i file, or click File and select an .A2i file from the list.
Viewing the A2i Editor Menu Features

The A2i Editor provides the following features to view and change an existing .A2i file.

Table 11-1

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
<th>Toolbar Icon Access</th>
</tr>
</thead>
<tbody>
<tr>
<td>A2i Builder</td>
<td>Opens the A2i Builder utility</td>
<td>Tools &gt; Launch A2i Builder</td>
</tr>
<tr>
<td>Migrate User Settings</td>
<td>Opens PC Transplant Wizard</td>
<td>Tools &gt; Launch Try Now</td>
</tr>
<tr>
<td>Edit Warnings</td>
<td>Opens the Edit Warnings dialog that allows you to add, delete,</td>
<td>Edit &gt; Edit Warnings.</td>
</tr>
<tr>
<td></td>
<td>and modify warnings for each version in the .A2i file</td>
<td></td>
</tr>
<tr>
<td>Edit Details</td>
<td>Opens the Edit Details dialog that allows you to edit the</td>
<td>Edit &gt; Edit Details</td>
</tr>
<tr>
<td></td>
<td>Details section of the .A2i file</td>
<td></td>
</tr>
<tr>
<td>Add Version</td>
<td>Adds a version to the .A2i file</td>
<td>Insert &gt; New Version</td>
</tr>
<tr>
<td>Add Section</td>
<td>Adds a section to the .A2i file</td>
<td>Insert &gt; Section.</td>
</tr>
<tr>
<td>Add Variables</td>
<td>Adds a variable to the .A2i file</td>
<td>Insert &gt; Variables</td>
</tr>
<tr>
<td>Add Registry</td>
<td>Adds a registry key to the .A2i file</td>
<td>Insert &gt; Registry Item</td>
</tr>
<tr>
<td>Add File</td>
<td>Adds a file to the .A2i file</td>
<td>Insert &gt; Files</td>
</tr>
<tr>
<td>Add Folder</td>
<td>Adds a folder to the .A2i file</td>
<td>Insert &gt; Folders</td>
</tr>
<tr>
<td>Add File Types</td>
<td>Adds file types to the .A2i file</td>
<td>Insert &gt; File Types</td>
</tr>
<tr>
<td>Online Help</td>
<td>Opens online help</td>
<td>Help &gt; Contents and Index</td>
</tr>
</tbody>
</table>

Editing A2i Entries

You can edit various A2i entries, such as registry and file entries. You can resolve the current entry and add value data for the entry. Value data can be a filename, a registry value, or any data that needs to be included in the .A2i file.
To edit A2i entries

1. Double-click the A2i entry to be edited
2. Click **Resolve** to resolve the entry. The value of the resolved entry appears in the **Resolved Entry** field
3. In the **Value** field, enter value data for the A2i entry
4. Click **OK**
Viewing the A2i Editor Menu Features